Zwift dropping every 100ft

Zwift was completely unusable today. Wattage dropping to 0 for several seconds at a time. 


My setup is exactly the same, the only difference was the update to Zwift.


Must say, if I didn’t know how good Zwift usually is, and that was my first encounter, I’d never be back.

Was using ANT sensors as usual, on windows, with a tacx bushido

That’s interesting. I had that similar behavior for the previous few days, but not every 100ft. more like once every 1000ft. I just assumed if was due to a weak wifi signal, but My cadence and heart rate didn’t drop out at all. I was using a stages power meter on ANT+ (the bettery is fine, I tried a new one too).

You would get more results if you submitted a ticket for help, rather than assume it is zwift’s fault. Zwift may not be perfect, but they assist everyone who requests help. Not many companies bother to care now a days.

Try unplugging your sensors and replug them in, perhaps in a different usb port if you have open ones. Make sure your computer isn’t updating windows or other programs while you ride. Try a test with no other tabs open (running youtube, live streaming Vuelta, etc) Basically, just to simplify matters.

Thanks Zee, but i’m a Zwift veteran, and have worked in IT support.

“Just to simplify matters”, the computer only boots windows for zwift. I’m a linux user and have no need for windows at all. I have windows updates turned off, there is nothing else installed.

I have had this issue once in the past, coincidence, right after an update, i did get ticket replies, but another update and problem went away.

Further, “to simplify matters”, all the sensors work fine if I try other training apps on ipads or tablets. 

I have 2 ant dongles and tried both during the glitchy ride.

Chances are it was a zwift issue and when i next login it will update and be ok.

Still frustrating at the time though.

I just resolved the issue with mine tonight. All I did was switch my stages PM to bluetooth and activate the mobile phone app. Zero frames lost.

Is direct sun light hitting the trainer? 

I don’t think this is a Zwift issue or we would be seeing more people posting about the same symptoms.

Sunlight, no. 

As explained at length, i tried to cut down the number of variables and it only really could have been zwift.

As i said, it happened previously, but was just after it became paid service and vanished as soon as it happened, and has been fine since, until this last run.


I would make sure Windows is fully up-to-date and see if that resolves the issue. 

What version of Windows are you running? I hope as an IT Pro you are running Windows 10 that is fully updated, including drivers.

Again, I don’t think this is a Zwift issue or more would be complaining of similar issues and I am just not seeing that.

BTW, I am also an Network Admin and I have also been on Zwift for close to 2 years and assisted many people in getting issues resolved on these forums. 

It certainly could be a windows error introduced by a zwift update.

As an “IT pro” I have nothing to do with windows at all, except for booting to run zwift and then booting back into linux. The requests for a linux launcher for zwift fall on deaf ears, despite zwift being cross platform already.

If i get the time i will see if i am up-to-date, seriously doubt it, and it raises the problems associated with zwift only supporting win, mac and ios, that i have to spend extra time maintaining a windows box just for this.

Again, zwift has worked fine, with this exact setup, for years (back to the beta period).

Twice it has given me a frustrating experience just after a big update. 1st time was a one-off, hoping this one will be too. 

The tacx app on my android device got and kept a constant device signal when i abandoned zwift, so again, it all points to zwift. Could have been a server load problem at that session.

I’ll revert if it happens on my next session, but really hoping it won’t.


I just got back to Zwift yesterday, after being a loyal TrainerRoad user for 1-2 years and had this awful experience that Gareth exposed in the opening message: 

“Must say, if I didn’t know how good Zwift usually is, and that was my first encounter, I’d never be back.”

Multiple power loss during a group ride event ended up throwing me back more than 1.5minutes behind. My setup details:

Laptop: Macbook Air running latest firmware version.

Trainer: Wahoo Kickr Snap 2017 with latest firmware version

Sensors: GARMIN ANT+ (Speed, Cadence & Heart Rate)

Bike computer: GARMIN 820

Other relevant facts: Streaming spotify while riding, Using both Laptop and Garmin 820 to record data simultaneously, Using a Mac Bluetooth mouse & keyboard sitting next to the bike, Laptop about 6-7 ft away next to my screen, NO external power meter used.

Seems like my issue was WiFi drop outs since spotify stopped playing at some times, I just called my internet service provider and will pay me a visit today.

If you have some recommendations on how to make my experience better, on behalf of Zwift team, I will appreciate it.

Questions, since there are IT experts in here:

  1. My Kickr Snap appears with FE-C and without FE-C in the Zwift devices, which one do you recommend I pick?

  2. Does Zwift demands WiFi data uploading or only downloading?

  3. How troublesome for Zwift could be to have lots of ANT+ & Bluetooth signals floating around my paincave? (e.g. bike sensors, trainer, mouse, keyboard, etc)

Thanks a lot, in advance, for any help provided.

Hi all, I just made some paincave adjustments and seems like it worked just great:

  1. Internet service provided improved the WiFi strength vía a modem tweak: changed channels to avoid other Wifi nearby interferences.

  2. I bought and installed a USB extension cable so the ANT+ receiver is close my rear wheel.

No power losses during a 1.5 hour ride yesterday.