Zwift doesn’t recognise me

Hi. I would be grateful if anyone can help. After pausing my subscription over the summer, I re subscribed last week and have paid my money. When I log into Zwift it gave me a free trial but having ridden the 25K the system won’t let my paid for subscription continue. I have even tried to pay again but I get a message saying I have already subscribed. I have tried everything I can think of even deleting the App and reloading it. At my wits end and ready to go elsewhere

Please provide more details of the platform you’re on and how you subscribed. (Apple, Android, direct with Zwift)

Hi. I’m use my IPad for Zwift and I subscribed through the App Store. Many thanks.

Try clicking Restore Purchase. It’s a regular Apple issue.

Where is Restore Purchase? I believe it has gone missing in the new Zwift User Interface.

There’s another link on this page that might help too.

Thanks Stuart. That has worked. It sure was difficult to find though. Perhaps it was me!

My pleasure. Glad to have helped.

Ride On!