Zwift Crashing on Big Sur


I am getting pretty frequent crashes on Big Sur. I have tried without BLE or without ANT+ and the result is the same… The crashes happen as I am riding, usually while riding with a large group.

The crash creates no log, no report. It simply drops to the desktop. I do have logs, but nothing in MacOS console.

Any ideas ? Is there a better way to diagnose what is happening ?


Seem like your graphics card (gpu) is not coping with the amount of riders on screen

Hmm Maybe. It’s an RX 580 which is a pretty decent card… But I am pushing it at 4K on a 4K monitor. I will try at 1440p.

I did some more testing today as it’s crashing for me very regularly…

I ran a ANT+ simulator with a crank based power meter and a HRM. I joined the Coco Cadence group and made sure my ANT+ simulator stayed with the group. This was done in 4K connected to a 4K monitor… After an hour or no crashes, I then let it run by itself for another hour and still no crashes.

That very same morning I did the same ride myself and it crashed after 10 minutes… The only difference is that when I am riding myself, I have a FEC connected to Zwift (en Elite Direto). So maybe the direto is sending a packet that Zwift doesn’t know how to handle ?

I am going to ride again next week but not connect the FEC and we’ll see.

But, very weird to say the least.