Zwift Crashing/Freezing Mid ride

Update here on December 19th.

For the last 18 days the original laptop I was having issues with was rebuilt with the default Windows 10 install. Everything went well until the 18th, with no crashes, when I installed 2 graphics driver updates, consecutively, suggested by the Dell Support Assist app.

I did these installs consecutively, which is never a good idea. Before each install I created a restore point. I have done a restore to the second of the 2 graphics driver installs. I’ll now test on this first driver update and see what happens.

I’ll post the details of the model and it’s parts shortly.

1 Like

Hi Tim,

I believe this is unrelated to the graphics driver / graphics adapter freezing issue, but no less frustrating.

Have you checked any threads on the wifi channel that ANT+ uses and your wifi router. From memory I believe it’s channel 3 on the standard wifi routers that try’s to unsuccessfully share a channel with the ANT+ protocol.

I also believe that if you disable this channel, or whichever one it is, and test again, you may have different results.

Ride On!

Hi All. Been dealing with this issue for some time now with zwift freezing mid ride. From what I have seen in the forum it looks like this would be an issue with a graphics driver. I have Windows 10 with Intel UHD Graphics and the most up to date driver 27.20.0100.9030. I have tried everything on my laptop and the freezing continues. I don’t have any issues with running zwift on my ipad or my android phone but with my laptop it continues to freeze on me. Has anyone determined what is a compatible Intel UHD driver version that does not cause Zwift to freeze? Does uninstalling the driver and re-installing fix the issue? Any help is greatly appreciated as this is super frustrating.

1 Like

I don’t know if this helps, but it is a relatively new article:

1 Like

One month later… and the problem isn’t solved yet. Zwift Support wasn’t very helpful on that matter…
I didn’t use the ant+ dongle and experienced today another zwift crash.
Last month 80% of my rides crashed midride…
I don’t know what to do…

I have a very similar issue (New i7 16 GB Intel Iris Pro on board graphics). The one common thing I have found is that the crash / hang is preceded by a Display 4101 error in the Windows event log. I rebuilt an old i5 8GB also on board Iris Graphics laptop with fresh Windows install and get the same issue. When looking at the log file, this usually happens during the UDP retry sequence.
I did over an hour on my ipad today, so don’t think my network is t fault.
BTW I started getting this issue since the 17 December update. Have sent logfiles to Zwift but no response yet.

Intel Iris (and UHD) seem to be the problem since the last update. There are different models, so it is not possible to compare. But as I wrote above - it is not only Zwift, this GPUs are known to be a bottleneck.

1 Like

Quick questions:

  1. Do you use Discord on the same machine? If so, do you have overlay enabled?
  2. Are you displaying FPS on screen?

For me i use discord on my phone and I don’t display any additional information on my screen other than the default items from zwift. I was getting the UDP connection timeout attempting to reconnect error as a common theme in my error logs so I’m assuming that’s the issue.

I followed these instructions as it may be a firewall issue: Your router firewall should allow all incoming/outgoing Zwift TCP traffic on ports 80 and 443 and all Zwift incoming UDP traffic on port 3022.

Since doing this I’ve been able to run zwift twice now with no freeze so will keep going in hopes that helped but unsure at the moment.

I started experiencing same Zwift mid-ride freezing issue roughly a week ago, it was running just fine before that. Mine runs on a laptop with Ice Lake i7, Intel Iris Pro graphics and Windows 10.

Updating graphics driver to the latest version, disabling BT and trying to run Zwift without any other background programs didn’t help. At this point I think that the culprit is Zwift’s latest update rather than anything else.

I filed a support ticket, still waiting for the solution from them.

1 Like


This is my first time using zwift and I will have to say that I am somewhat disappointed.

I’m experiencing the same issues with zwift freezing up. In looking at the posts, I’m seeing similar error messages in my computer’s logs. I am weary of updating drivers as I dont believe this will fix the problem.

I have a brand new Asus laptop and a new kickr. Hopefully, swift will rectify this or I will be taking my training to another platform.

1 Like

I’ve been having similar issues with rides freezing - been in touch with Zwift (not an easy pricess) and no resolution - they were sent all the log files etc they requested and get replies saying they havnt heard from me for a while etc Get onto the online help (not that useful either and hard to get to) and no resilution. Crached again 30 mins into a ride today. Taking my money but not solving my problem! Any final resiltions?

Hi John,

I was in touch with a rep via a chat session. They sent me a couple links to help documents (one was for networking issues and the other was how to reinstall zwift). I’ve done neither as I firmly believe those steps wont rectify the problem.

At this point I’m not sure what to do. I may just go to another platform and forget about zwift.

I have a brand new computer (asus vivobook) and would assume this is the ideal situation. I was thinking of running a GPU test (GPU is Intel UHD) using something like 3DMark to see if there is truly something amiss with my computer’s GPU. I’m not that tech savvy but at this point I’m not sure where the problem is.

I’m actually a little relieved to see this thread. I bought a new Laptop and signed up for Zwift last week. The first day I used it, it crashed twice. The second day, it ran fine. Today, it crashed several times.

I also have Intel UHD graphics. The laptop is a Lenovo Ideapad 5. I bought it open-box from BestBuy, so don’t know whether it was faulty and someone returned it, or if the problem is Zwift. I haven’t had any other problems with the laptop (but I’ve only used it for some light browsing).

I dropped a bunch of files into Zwiftalizer, and many do not show network errors at the end of the ride, when it freezes, just the normal network errors at the beginning of the ride.

I don’t get a specific error message. The screen just freezes, I can still hear the sound, and sometimes the entire page goes white. Eventually, I get a “this program stopped responding” message.

I sent the logs to Zwift support two days ago, and I got a message that they are going to “escalate” my case, but I haven’t gotten any info.

What are the specs of your computer? CPU, GPU, RAM etc

Hi ,
also form a brand new Lenovo PC with I5 10th generation , with UHD graphics stops random during a ride,after aprox 30 minutes , but the time is random , after this crash the only way to restar zwift is reboot windows , if i try to re-start zwift without reboot the application stops at connection.
No behavior changes reistalling videodrivers and Zwift

I followed these instructions as it may be a firewall issue: Your router firewall should allow all incoming/outgoing Zwift TCP traffic on ports 80 and 443 and all Zwift incoming UDP traffic on port 3022.

I had the same thing and they are “escalating” my issue as well. Although, I followed these instructions as it may be a firewall issue: Your router firewall should allow all incoming/outgoing Zwift TCP traffic on ports 80 and 443 and all Zwift incoming UDP traffic on port 3022. I haven’t had a freeze or crash in the last 5 times using zwift. Hopefully didn’t just jinx myself

Thanks, Edz. How do I set my router firewall? If it helps, I’m on Verizon.

That was the tough part for me. Not having any info to go off of to find where the settings are to adjust. My only suggestion is to google how do i open a port on windows firewall and there is an article from howtogeek that I used.

Once again I’m not sure if this corrected the problem but as of now I haven’t had an issue with the freezing since i updated the firewall ports.