Zwift crashes while saving (Release: Dec 3, 2018)


(Tobi Scheller ) #21

For me both. Free riding and workout crashes before save window appears.
Using ANT+ all the time.


(✌ Micha | ☠ Fc St Pauli ☮) #22

Same ■■■■ like all others here.
Since Update 1.0.32190 Zwift crashes after finisch my workout…

Windows Error Log: @ 03.12.2018 Timestamp 20:56:17

Name der fehlerhaften Anwendung: ZwiftApp.exe, Version: 0.0.0.0, Zeitstempel: 0x5c02324e
Name des fehlerhaften Moduls: ZwiftApp.exe, Version: 0.0.0.0, Zeitstempel: 0x5c02324e
Ausnahmecode: 0xc0000409
Fehleroffset: 0x00000000006cdfab
ID des fehlerhaften Prozesses: 0x2258
Startzeit der fehlerhaften Anwendung: 0x01d48b3973442087
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Zwift\ZwiftApp.exe
Pfad des fehlerhaften Moduls: C:\Program Files (x86)\Zwift\ZwiftApp.exe
Berichtskennung: 7e63732a-f735-11e8-814e-3c4a92df7fc4
_Vollständiger Name des fehlerhaften Pakets: _
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

Last rows Zwift logs @ 03.12.2018

[20:56:14] Loading WAD file ‘assets/UI/WhiteOrangeTheme/JerseyIcons/JerseyIcons.wad’ with file.
[20:56:14] FE-C SIM GRADE -0.006
[20:56:14] ANT : Transfer Completed.
[20:56:14] ANT : FET grade set successfully
[20:56:15] ANT : Rx Fail on channel 3
[20:56:15] FE-C SIM GRADE -0.006
[20:56:15] ANT : Rx Fail on channel 2
[20:56:15] ANT : Rx Fail on channel 3
[20:56:15] ANT : Rx Fail on channel 2
[20:56:16] FE-C 17 received
[20:56:16] ANT : Transfer Completed.
[20:56:16] ANT : FET grade set successfully
[20:56:16] ANT : dID 1139663 SW Revision 39167 SerialNum 25551
[20:56:16] ANT : dID 1139663 SW Revision 39167 SerialNum 25551
[20:56:16] FE-C SIM GRADE -0.006

pls fix that


(Rolf Pfister) #23

ANT+ only


(Rolf Pfister) #24

same Exception code: 0xc0000409 here


(Ben Fricker) #25

Same here.
After “Finish Ride” Zwift goes straight to Desktop.
The Ride ist downloadable via .fit in my Profile and i can upload it manually to Strava.
It’s since the Update.
No changes in my System.
All Sensors via ANT+

PC-Specs:
Intel Core i5-3340 (4 x 3.1GHz)
8 GB DDR3-1600 Dual Channel
120 GB SSD Intel 520 (SATA3)
ATI/AMD HD7850 with 2 GB GDDR5
Win10 x64 v1809
Internet ADSL 16/2,4 Deutsche Telekom with a TP-Link Wifi Stick 300MBit (stable connection)

Don’t know if any hm are saved to Wahoo Climb Challenge. I accepted it today.


(Matthias Wolf) #26

Seems to be a german problem!?


(Chris Larese) #27

Same here. No crashes before update.
Yesterday and today crashes when saving game.

Connection to Smart trainer: Ant+
Windows 7 64bit. Companion App on Android 8.1.0
Zwift Connected to TrainingPeaks

Yesterday and today I was entering the game, riding couple of km, enterig an event, finishing, riding a few km and then exiting:
Yesterday tried exiting and saving game with Companion app -> On Windows program is not responding.
Today I tried exiting and saving game on Windows directly -> same thing. Companion App Game was still active, and I could save it there, BUT it didn’t (as usually) save the activity with the name of the Event but only Default name “Zwift 2018/10/04” AND I think so far I got no points in the wahoo challenge.

Yesterday no record in TrainingPeaks. Today initial km ridden before event are recorded in Trainingpeaks but not the event itself (maybe that helps, finding the issue?)


(Klaus Kirchfeld ZRG ) #28

One observation I did is, if I skip all efforts of a workout the savescreen appears. No idea if this will help. Seems generated data in an race/workout is the problem.


(Matthias Wolf) #29

Nope. Here crash without race or workout, just free ride :0(


(Dennis Neumann) #30

Crashed at the end of the workout before i was able to upload it.


(Ben Fricker) #31

Yep, it doesn’t matter if free ride, workout, group Ride or Race.
And yeah, I’m german.
Internet via 300MBit WiFi (stable) to ADSL 16/2,4 (scheiss Deutsche Telekom)


(Matthias Urech (Nidibikers)) #32

Same here. Crash happens after upgrading Zwift for Windows on Dec 3. Since then I did two workouts (from FTP Builder plan). No crashes before update. All sensors connected with ANT+. Bluetooth is disabled on Windows 10.

The crash happens when I click the [OK] button of the workout summary. Upload to Strava is not done. Data can be recovered by manually uploading file “inProgressActivity.fit”, but only workout data is in .fit file. I did a post ride after the workout and this data is not in the .fit file.

Yesterday, workout was not marked completed in workout plan. Today it worked. On both days, no expierience points, no Wahoo climb challenge progress. Not cool. I sent all logs to support.

EDIT: I noticed that a lot of people in this post seems to have german as their native language. Is this maybe a unicode (UTF-8) problem?


(Martin Betz) #33

Same here… :frowning_face:


Z crashes when I click "Finish Ride"
(Matthias Wolf) #34

Free ride in my case. But all the problems seem to be from germany.


(Matthias Urech (Nidibikers)) #35

Or Switzerland :wink:

Anyone from Austria and Northern Italy?

Looks to me that this is a language related problem…


(Reto Breitenstein) #36

Same problem with free rides in Switzerland.


(Chris Larese) #37

Yes, Austria here. Maybe it really is a German language related issue.


(Dennis Neumann) #38

i know from 3 others (Germans) that it crashed after the last update. Should be easy to reproduce. Better test those updates before going live :rage:


(The Rocketeer) #39

Yap, same here! Second day in a row it crashed and saved all but the last 2k or so… No upload to strava of course for the recovered workout parts. Furthermore theses crashed and recovered workouts are not counted towards weekly goals, all time stats etc.


(Ben Fricker) #40

How can I change the language?
Would have no Prob if Zwift was in english and could test.