Zwift crashes mid ride with no error Mac

Fresh install of Zwift 1.60.0 on a Mac Mini running OSX 14.4.

Every ride Zwift will just close down with no warning and no error messages. Nothing in Console to show any error. Its like the window has just been closed. If i re-open Zwift, non of the previous saved devices (Kickr, HRM etc etc) are saved and i have to search for them. If i open a new ride, the previous activitiy then shows in my profile, but every activity says its stopped at 10m 7s regardless of course and even if the crash happened at 20mins etc.

Have made sure Mac is up to date, disabled Garmin express, and restarted several times, but the same again.

Any suggestions

The automatic saving process doesn’t run constantly so it’s expected that you will lose some minutes of a ride recovered that way.

I would try doing a clean reinstall of Zwift next.

You could also try contacting Zwift support and ask them to analyze your log file. They may tell you to update your video drivers but of course you can’t so you can ignore that one.

Could also go to settings and disable video screenshots, though I can’t say I’ve had any problems with stability on my M1 MBP with it turned on. It does lower frame rates and increase CPU utilization.

1 Like

Thanks. Will try a fresh install and disabling video as well . Super frustrating as it’s only when I’m 10-20min into a ride it does it. Just fired up my old Windows laptop to start my ride again

Tried a few things as suggested, but looks like its because i’ve not got a Metal Mac and even though i’m running 14 via OpenCore (which runs better than my 15yr old windows laptop) it will keep crashing.

I’ve tried running the script as per a post i found to copy over the Metal App, but it didn’t work

Back to windows it is

Yeah I think the non-Metal macs are dead to Zwift now.

Scrap what i said. When i did the whole <<cp ~/Library/Application\ Support/Zwift/ZwiftApp ~/Library/Application\ Support/Zwift/ZwiftAppMetal >> bit i didn’t think about navigating to the folder and opening the non metal version of the app. Serves me right for not reading the whole page.

One to test another night