Zwift Crash when scanning Bluetooth

Hi Guys,

Using Zwift for two years, only my iPad (iOS up to date + App up to date).

Since a week, I have a weird issue :
When I have in my pain cave, on the bike (using a Tacx Bushido), starting the Zwift app and try to connect to it, the app Crash, every time.
BUT
If I go to my living room (nearby), it connects to it without a crash.

NB : Did the same experience for Zwift running with the Stryd and exact same result (crash in Pain Cave / works from leaving room)

So the workaround is to connect from the living room and come to the pain cave but as you can imagine it is not very convenient… not sure what is happening here.

I tried everything, restarting iPad, reinstalling the app with no luck.
To be noted that I don’t have any other Bluetooth device in the pain Cave.

Does anybody have an idea about this ?

Thank you all,

MS.

Just a guess but could be 2.4GHz radio interference from any number of devices. BT broadcasts using this frequency as do baby monitors, cordless phones, remote controls and WiFi. You might try changing to your WiFi channel. Google which have less interference with BT.

Hi Bob, thank you for the idea.

Indeed I have a Google Mesh nearby, I tried to unplug it to try but no luck.
Very weird.

Zwift released a fix for a crash in pairing a couple of days ago. Go into the App Store and make sure you’ve got that update.

Indeed, I have an update today Steve, hopefully will fix it. Cheers.