Zwift Companion Won’t Connect - Game Mode

Hi, guys.

I’m having trouble connecting Zwift Companion to in-Game mode.

I never used to have a problem (previous house/router/WiFi) but I’ve tried everything I can think of and have already looked through the support pages.

I’m running Zwift on my MacBook (running Mac OS Big Sur beta) and Zwift Companion is on my iPhone 11 Pro Max running iOS 14.2 (Public Beta, GM version).

Both devices are on the same WiFi network and the same 2.4 ghz band.

I’ve tried reinstalling/logging out/restarting and starting the apps in a different order.

I also tried to allow ports (after lowering my Router firewall) but it doesn’t seem like a straightforward process on this terrible ZTE router I have (I previously used either Netgear or an Apple AirPort Extreme, which made these things simple).

I hadn’t considered the software on my Mac and phone being the issue, simply because both apps run otherwise flawlessly.

Also, if I mismatch the WiFi bands, I can make companion work. If they’re both on 2.5Ghz, or 5Ghz, it doesn’t work. If the phone is on 5Ghz and the laptop on 2.5Ghz, it works perfectly - annoyingly I can’t get the 5Ghz band in my garage.

Any ideas? Thank you for your help.

Try disabling Wifi Assist. Don’t fight me if you did this years ago.


It’s a great shout, but you’re right; I did it a while ago. In my old house, it just made the connection unstable so it would enter and exit game mode when it decided to assist the WiFi. Now I just can’t access it at all!

Sure your router / modem is not separating the 2.4Ghz and 5Ghz band (even if it shows the same subnet)? Dont have Client Isolation enabled by chance for your wifi?

What is the router/ modem model / brand?

The router is Zte. H298A, specifically. I’m not completely sure what you mean about bands. I see both separately and they’re split in settings.

It randomly connected last night after I had spent hours trying everything I could to no avail, the previous day.

Only difference was that I was using a Kickr Core instead of Snap this time. Can’t see how that would have an effect.

Same problem using an iPad as the main device and an Android for the companion. It’s always worked fine up to know but no go for the past couple of weeks. I have the latest versions on both. Something’s up !

Same here, Apple TV and iPhone. The only way I can get the Companion App to work consistentely is to turn the cellular data off on my phone.

Same issue.

Been using Windows Desktop and an iOS iPad as Companion app. Been working for years, then today (11/8/20) the Use Zwift option is greyed out.

When I switch to built in bluetooth, it will connect.
So I know that my Wahoo/HR/Cadence sensor are fine. I can connect those to my iOS iPad as well.

So something it up with the connection to the PC and iOS. Uninstalled on both PC and iOS and nothing.

Both devices are on the same network as well.

i believe it was the latest companion app update of 3.19.1 (android, not sure if those on IOS is the same issue or not) that actually kill off the bluetooth connection to PC/laptop… i know for my case the problem only occurred after the update, and the only solution i found was to downgrade to ver 3.19.0 the 8th October update that actually solve the problem.

Got the same. Zwift on iOS. And zwift Companion on Android. No game mode since about 1.5 weeks
You said you remove app on Android and reinstall older version?

yes… but you can’t do that officially via google play store, so you will need to download the older version from another website, and of course your phone will warn you about this… but i’m pretty sure it’s safe…