Zwift companion iOS 14.3 does not load map

Since the recent Zwift Companion (ZC) upgrade to version 3.20.0 (1078) on iOS, the ZC app has been working perfectly. Prior to that ZC usually failed to load the map while I was riding, even though both ZC and the game (running on an iPad) were on the same wifi network and frequency (5ghz).

After upgrading iOS and iPadOS to 14.3 a couple of days ago, ZC no longer loads the map while I’m riding.

Has anyone else experienced this and has a solution? If there’s any Zwift staff reading this, when will there be a ZC release that will reliably detect that the logged in user is riding and load the map (along with the usual ZC functionality)?

1 Like

I’m not an iPhone user but have been having same problem on Android for a few years. Workaround for me is I hit the STOP ride button - when the screen changes to “Save Ride” I exit from that screen and the map comes up. Might be worth a shot.

Also someone else mentioned they just go to rider list, select a rider, hite the Ride On button and exist - and the map comes up (again, this is an old Android workaround though so may not work for iPhone).

Hi Dean, thank you for the suggestions. I tried both but unfortunately ZC would not load the map. I tried the following while ZC was open

  1. in-game -> Menu -> End Ride -> Back Arrow icon
  2. in-game -> Menu -> End Ride -> Trash Can icon

and then tried the following while the game and ZC were open
3) ZC -> give a ride on to someone -> tap HOME
4) ZC -> give a ride on to someone -> kill ZC -> start ZC

Worth a shot - I actually hope its quite common for iPhone as that way they will fix it. For Android, its not common so I have to suffer. Good luck!

1 Like

@sc31
Do you have a VPN running on either the iPad or the iPhone? A VPN will prevent one device from seeing the other. Working from home using a VPN, I have to remember to disable the VPN before I start Zwifting.

Please also check any firewall settings and app permissions - when you update the OS, it’s very possible that the OS defaulted to stock security settings for app permissions. It’s worth checking those things too.

I too have the same problem. App doesn’t connect at all while zwifting.

1 Like

@shooj
Fair point about VPN. I do not have VPN running on either device so in this case VPN isn’t a factor.

As far as I can tell, the iOS security settings for ZC haven’t changed. My hunch, based on my experiences with ZC so far, is that ZC is not fully compatible with iOS 14.3

Prior to ZC version 3.20.0 (1078), ZC worked only 2 or 3 times out of the approximately 40 or 50 rides in which I tried to use ZC. After the ZC upgrade to version 3.20.0 (1078), ZC worked every single time… until the iOS upgrade to 14.3. ZC even worked the day before the iOS upgrade.

I think the root cause is ZC’s core logic in terms of detecting when the logged in user is riding. I can see myself “zwifting now” in the activities section of the ZC home screen, but ZC does not use that information to load the map (sorry, I don’t have a better term here for describing what ZC should do when you’re “zwifting now”). For me, it is illogical that ZC can see the logged in user as currently zwifting, but doesn’t load the map.

Granted, the game still works and I am able to ride but without ZC the experience is a wee bit degraded.

1 Like

This is somewhat interesting. I don’t normally run the game (let’s call it ZG for now) from a PC, but a new version of ZG was released today. I upgraded ZG on my PC and literally moments after I hit “ride” in ZG (even though I have no trainer connected) and my avatar appeared, ZC loaded the map. It’s worth noting that I checked my router and all the devices are on the same wifi network and frequency.

Granted, there are multiple variables at play here, but I think that this is a software issue. Probably more on the ZG side than the ZC side. Once the latest version of ZG for Apple products is released, I will try again.

You might wish to keep the devices that run Zwift and ZC next to each other and then reboot your WiFi router. Many routers today band steer between 2.4 and 5Ghz. If the SSID is the same it should not matter but Zwift still says that both devices need to be on the same band. Keeping the devices near each other when your network comes up will help them both grab the same channel.

@Bob_Gorman_Splunk_65
Thank you for the suggestion, the devices are less than 1 meter (appx 30cm) from each other, are on the same wifi network (SSID), and are on the same band (5 ghz). The devices always connect on the 5ghz band, I have checked multiple times, before and after ZG, ZC, and iOS upgrades.

I think the issue in this very particular case is with ZG; specifically in the way ZG broadcasts whether or not the logged in user is zwifting or not. In general though, ZG and ZC pairing ought to be seamless.

@shooj
Not sure if you work for Zwift, but can you report this?

@sc31
I do, and yes, I’ll flag it up.

2 Likes

Same problem here. Since updating to latest ZC iPhone yesterday, it will not load map, or even load at all when game is running, only when not in game… Is this a rogue version? No problems up to that date with latest iOS (14.3).

1 Like

Long shot but may be related … iOS 14 added private wifi address have you tried with this set to off ? It’s under the wifi connections and may be why it’s not connecting …

Ride on

Sara Lance

The solution was to change the network settings for ZG in iOS (as @shooj touched on).

I think it would be helpful for ZG to ask (via a popup or prompt) for permission to scan the local network for devices. Other apps, such as youtube, ask for permission if it is not granted when the app is launched. I think this functionality would, to some extent, make people aware of the issue and solution automatically. Otherwise, I think most people just get frustrated with ZC when in fact the root cause is on the ZG side and totally not transparent.

after the recent ZG and ZCA updates for the Japan rides I also had a map problem within ZCA.
Apple TV 4K (ethernet) iPhone 6 on same network WIFI

Everything worked on the ZCA app, ( messages, events, other riders, dashboard…) EXCEPT for the positioning and data on the map page) ( power up, icon selection were ok on that page)
There was a map I could scroll around ( and pinch zoom, but zoom icon not working) but no arrow or dots of other riders. Map did not move with my ride. ( on other page othere rides were shown)
After about 30 minutes into ride, it started working.