Companion App - In Game Map Function not loading when ride starts

Hi - when I start my Ride, the ZC built in map function does not load. Note, I can see my trainer paired before I start my ride, and the map was previously loading. It stopped after I paired my Apple Watch, which I can no longer see under paired devices.

  • ZC is on my iPhone and this is connected over the same network as my Laptop which is where I am running Zwift.

  • I have deleted and reinstalled both Apps from Laptop and iPhone [didn’t wok for me]

Same here. The map will not load so the in game app is pretty useless. I am on android. There has been no new changes on my part, it just stopped working. The app is still linked to Zwift because other things still update. I would also appreciate a response/fix.

If the map screen has stopped appearing, it means your phone has stopped being able to see the Zwift client device on your network. It only needs to see the Zwift client for that map screen, which is why you can see other things updating still on ZC.

Try rebooting your home router for a start. Has something changed on that front? Something is stopping the phone and client from talking.

Hi, thanks for your reply. I saw that suggestion elsewhere, I tried it and it worked!! I had already tried everything else I could think of and wasn’t expecting this to have any effect but it worked perfectly. Thanks again.