Zwift Companion interference with Zwift on Apple Tv4

pairing-error

(.) #1

Continuing the discussion from Recent Companion App/Apple TV bluetooth problems connecting:

I use the following equipment just to make things clear.
Wahoo Kicker 2
Wahoo cadence
Wahoo Tickr
Apple TV4

First off i noticed that there is a drop of cadence which showed simultaniously on Zwift on my TV on Apple Tv4 and on Zwift companion on my Apple Iphone 8 plus.
This never happened before.

The next thing that happened the Zwift also seemed to loose the EGR, suddenly pedaling becomes very hard and or you pedal easy, but the Avatar is just spinning like crazy and going nowhere.

My equipment with Zwift worked perfectly before, and as of this morning a battle to start to Apple Tv4 and Zwift Companion to connect.
I have simular problems as discussed before by other users loosing connection or trying to connect.
It seems to me that the culprit is the Zwift companion.
I have tried everything,deleting all the apps ,reinstalling,switching everithing off and on again (Wahoo Kickr,Apple tv4), changed the batteries on the Wahoo cadence and the Wahoo kickr heartrate.
But to no avail.
I realised it is not on the Wahoo side where the problem was.

I then tried out different variations first connect the Wahoo Kickr and the Wahoo cadence on the Apple Tv4 and then using the Zwift Companion to connect the Wahoo Tickr heartrate.
The Apple tv4 as we know only connects 2 bluetooth apps, and then request to connect the 3rd app via the Zwift Companion app.
That is what i did, but it did not pick up the Wahoo Tickr heart rate and just searches and if you click on the top right of the Zwift Companion bluetooth icon it cannot find the Wahoo Tickr.
In the settings of the Iphone under bluetooth the wahoo tickr is connected.
So now i connected first on Zwift on the apple Tv4 the Wahoo kicr and also the Wahoo tickr heartrate which it connected and then on the Zwift companion i connected the Wahoo cadence, which instanly also connected.
The problem now was on Zwift when you ride power,cadence and heartrate showed, but because it seems that the Apple tv4 is not connected to the cadence the EGR info required is missing and the same problem arrise by pedaling becomes very heavy while the avatar is standing still or pedaling becomes with now force , you just spin and the avatar just stands still or hardly moves .

I have also experienced that you cannot calibrate spindown on the apple tv4 like this, but if i use just Zwift on my Ipad which then are able to connect all the wahoo apps the kickr,the cadence and the tickr heartrate the calibration spindown works and evering else as well.


(Aaron Zwanzig) #2

There are lots of discussions about how unstable connections through the companion app to apple tv can be.
I have had a far better experience pairing a 3rd peripheral to the apple tv by using an ant+ to bluetooth bridge. I use the 4iiii Viiiiva heat rate monitor. The NPE CABLE is another option.


(.) #3

Hi Aaron

I dont think thats the way to go.
It does not help to buy more and more equipment to solve soft ware problems.

The system worked perfectly for about two years and now suddenly
not.


(Aaron Zwanzig) #4

You could try working your way through troubleshooting the companion app connectivity. What i know is that my issues with it wen’t away when i started using an ant+ bridge.


(Aaron Zwanzig) #5

Hey, @_SPINAGEAR_FAST, it could be that you just need to reestablish a proper pairing through the companion app.

When you go to pair whichever device through your iphone with the companion app, make sure that device is not paired directly to the iPhone. Let zwift do the pairing. Unpair it through the bluetooth settings on the iphone. It might help to remove the battery for 30 seconds to ensure it isn’t paired to anything.

Start zwift, pair your kickr, pair your tickr, then force zwift to use the companion app by trying to pair the cadence. On the popup dialogue choose to use the companion app to pair additional devices.

At this point the pairing screen will likely say there is no signal from the cadence. Unpair the cadence by clicking on its tile in the pairing screen. Then re-pair it by clicking that tile again. You should now see the cadence listed as an available device along with a phone icon.

If unpairing-repairing doesn’t work, take the battery out of the cadence for 30 seconds and replace it. You should then see it as an available device along with the phone icon.

Good luck!


(Darren) #6

I’m having this very same issue with my Wahoo devices. I can get two of them to connect just fine to the ATV4K. The third device is then recognized by the ATV but prompts to use ZC. It seems to connect but with no signal. If I click the tile to disconnect then click again to reconnect, ZC does not see it. HOWEVER, when I look at the list of BT devices connected to the iPhone, I can see the sensor in the list. I can also see it with the Wahoo Utility app and get its current reading. There is no option to disconnect it even with the Wahoo app closed.

I’m wondering if there has been a recent update to my Wahoo devices or Apple’s BT that allows the sensor to connect to the iPhone automatically? ZC can’t seem to connect before it connects to the iPhone. Ive tried various methods and timing of turning the BT off then on again with no recent success. Any ideas?

One theory - when the guest world feature was launched, ZC doesn’t connect right away, pending your choice of worlds (which happens after you connect devices). It seems the 3rd sensor then connects to my phone before ZC gets itself fully connected…


(Huwelfedus) #7

I always use the Zwift Companion as my source, I gave up on connecting directly to Atv4K about two months ago.
It works flawlessly and so much quicker at the start.


(Darren) #8

Hlvd, are you using Wahoo sensors (for heart rate or cadence)? I think my problem is with Zwift Companion or the iPhone. I don’t have any issues connecting sensors to ATV4K, nor do I have issues with ZC connecting to ATV4K. For some reason, I can’t get ZC to “see” my 3rd sensor even through it is showing connected to my iPhone in its list of Bluetooth connections. Thanks!


(Aaron Zwanzig) #9

Bluetooth is monogomous. A bluetooth sensor can be paired to only one head unit at a time. If the cadence sensor is paired directly to your phone, it will not pair to the ZC app even though it also is on your phone. Also, for some reason, even though the ATV has no more bluetooth slots to fill, when switching over to use the ZC app for pairing it will sometimes grab hold of the device and won’t let go making it invisible to the ZC app.

My recommendation to you to get your cadence sensor paired to the ZC app would be the following:

  1. Take the battery our of your cadence sensor for about a minute to ensure that anything it might be paired with disconnects.
  2. Turn the bluetooth antenna in your phone off.
  3. Start the ZC app on your phone.
  4. Start up Zwift and pair your trainer and hrm as per normal. Make sure the ZC app is connected to Zwift.
  5. Replace the battery in your cadence and try to pair it to Zwift. It will ask you to use the ZC app. Turn on bluetooth in your phone. Once bluetooth is on say ok to use the ZC app.
  6. The cadence tile in Zwift will say “No Signal”. Unpair the cadence and then repair it in Zwift by clicking on its tile. If at this point it works, great. If it doesn’t show up in the cadence pairing window or if it does shows up but without the phone icon, then it isp paired to something else and won’t pair to the ZC app. Continue with:
  7. Remove the battery from the cadence unit again. Wait at least 30 seconds and then replace the battery.
  8. Try again to pair the cadence to Zwift by clicking on its tile. Hopefully at this point it will show up with a phone icon and all will be good.

(Huwelfedus) #10

I’m sure that’s your problem, try removing your sensors from the phone’s list of paired devices and ZC should then find it.
I might be wrong but If it’s already paired to your phone ZC won’t see it as it’s already in use.

None of my sensors are in my devices list, Wahoo Tickr, Wahoo Kickr, Garmin Vector 3 and Bontrager cadence sensor, they connect directly through ZC.
They always connect and I don’t bother with connecting to Atv4k.


(Darren) #11

Thanks for the help. After a good hour of playing with batteries and sequence, I kept getting the same results - sensor not recognized by ZC but visible in my phone’s BT list, and I could see the value in my Wahoo Utility app. Finally, I decided to delete the Wahoo app and started having success. Even though that app was not running in the background, it evidently was blocking ZC from seeing the sensor. Had good success with both the ATV4K and ZC app (probably more consistent success with all 3 sensors connected to ZC + phone but that starts to max out the phone’s number or BT connections). I hated to delete the Wahoo Utility app as I use it from time to time to check battery levels in my HR and cadence sensors but it’s easy enough to download again later.


(Huwelfedus) #12

Hi Darren, there’s no need to delete the Wahoo app, just the sensors from your devices list in settings


(Aaron Zwanzig) #13

I’m glad you found the problem. I haven’t paired anything through the ZC app in so long I forgot that when I was working through my issues with it I had force-stopped wahoo utiltity and several other apps which could have been pairing in the background. Good stuff.

That said, you can keep wahoo utiltity on your phone, just force-stop it after any time that you use it.


(Darren) #14

I was not able to disconnect the sensors in the device list. At first, when I couldn’t get the 3rd sensor to connect, my device list screen looked like this:


Note my TICKR X is connected but it does not have a “circled i” after it. I believe this tells me that something else is managing the connection with this device and it wasn’t the Zwift Companion. However, I could see the value of the TICKR X in my Wahoo Utility app. It would not allow me to tap on it and “Forget this Device” like the other devices with the “circled i”.

After I deleted the Wahoo Utility app and got the ZC to work, my device list looked like this:


You can see my trainer, cadence sensor and TICKR X all connected but presumably being managed by ZC, not my phone.

If anyone knows more about how “competing” apps choose to manage the connection of a particular Bluetooth device, I would love to hear more and I think this would help many with their ATV connectivity issues. Although frustrating, it’s nice to have a solution!

Again, thanks for all the help and Happy Zwifting!


(.) #15

Zwift Sorted.

First of all before 3 of Feb 2019 everything worked.
About the 2nd or 3rd ther was a Zwift Companion update, that was when everything did not work so nice to connect anymore.

The solution:-
Which in have tried now the last 4 times is the following:-

First do not connect the power to the Wahoo Kicker and the Wahoo tickr heart rate monitor before you do the following:-

  1. Check that your bluetooth is on your phone(I have a Iphone 8 plus).
  2. Start the Zwift Companion app on your phone. You will notice it trying to connect, just leave it on.
  3. Start the Zwift app on Apple Tv 4.
  4. Now connect the Wahoo Kickr with the cable to the electrical plug and just turn the pedals a couple of times to activate the Wahoo Kickr and the Wahoo Cadence(it is attached to my bike,s left hand crank).
  5. Now fit the Wahoo Tickr with the strap to your chest.
  6. Now on The Zwift on Apple TV 4 connect all the power sources; the Wahoo Kickr, the Wahoo Cadence, the Wahoo Tickr and if you want the Wahoo Kickr to control the ERG MODE also connect the Wahoo power which is normal towards the right of the screen.
  7. Now start the ride and you will see that the Wahoo Companion will also connect and start.

(Timo) #16

Super, will try this on next session.As for me everything has worked super before last update.
Hopefully everything will work again.

Thanks // Timo Springfeldt


(Timo) #17

it just worked super !