Zwift Companion App sensor connection issues

Since the last Companion App update, I am having issues connecting sensors to Zwift running on my Apple TV. I can not get the ZCA Bluetooth icon to go from orange to blue.

I have had no problems up until recently.

The ZCA is on the same network and connects Quickly with no problems

I get the usual message on trying to connect a third sensor so agree to use ZCA

I have all other nearby Bluetooth devices disconnected

I have disabled mobile data

I have tried ZCA on three devices. Two Android and one Apple
I do understand the process and how to use ZCA as a bridge but it refuses to search.

Occasionally it will suddenly decide to turn blue and connect but this is rare and after being the selected source for 30 mins plus

I really don’t know what else to try and can only assume that there is a problem with ATV.

If I access the ATV Bluetooth menu, “Other Devices” Nothing is found. Not sure if anything should be.

Really don’t know what else to try??

That’s interesting because I can get the Companion app to connect (blue device icons) - I just keep getting ‘no signal’ messages over the top of the connected devices.

I get no signal if my Bluetooth icon is orange because that means it hasn’t connected via the companion app and the ATV can only connect to two devices hence no signal on one of them.

I have the same problem Alan.
My sensors had been connecting on the companion app until the last IOS update. I have restarted all devices but still no luck. I did note all my sensors had connected to the phone bluetooth but as you say the campion app icon is stuck on orange. I am using an apple TV and also tried using my iPad that had previously been working but the same result.

One tip. you can mirror the screen on the apple TV.