Zwift Companion App Map Freezing plus Zwift crash saving ride

Not used Zwift for a few weeks but was working fine last time I did.

But this evening had loads of problems with ZCA - things were ok in Zwift world for my ride with other riders displaying but on the App the map wouldn’t update, it’d load where I started but then freeze position, power/hrm figures etc. Running a power-up from the app screen worked but that was it. Then it would occasionally try to refresh but freeze again, also not showing dots for any other riders. Also dropping out of the map screen totally several times. Restarting iphone didn’t help, neither did deleting the app and reloading.

At end of main activity zwift got stuck in the garage screen for ages then said it had lost connection when I tried saving the activity then zwift froze and got windows error that it wasn’t responding. Logging back in it only saved basic details for my ride, and same issues again with the companion app.

Tried setting Companion app to PC connection from pairing screen but no different than using built in bluetooth. Also after previous problems with bluetooth dropouts/interference I’d made sure no other apps were running such as Wahoo etc before I started Zwift. The map would start to refresh at start of an activity but only for a second or 2 then freeze again.

Anyone else seen similar recently?

So you don’t think it’s only you :wink:

Twice now since since the latest Companion app update, I have had it sorta freeze up. My position wouldn’t update but I could move the map around. I force quit the app both times and it sorted itself out :man_shrugging: I pair directly w/an AppleTV not via Companion app. I don’t believe I have ever had a Companion app issue before this one. As a result, I’m not too bothered.

Yep that similar to my issue - could move the map but other users not showing up or my position updating. But closing and restarting etc didn’t help :frowning:

Plus everything seemed slower going through trying to save activities, exiting the game etc which left me stuck listening to the annoying new menu music for longer than I’d wished :roll_eyes: