Zwift Click not staying connected

https://support.zwift.com/using-the-zwift-companion-app-as-a-bridge-ByAnUzlLj

Normally I just have the companion app open on my phone and on same network as my device running Zwift.

When you get to the pairing screen on Zwift Game, choose pair through phone.
First connect your trainer, Power, Cadence, Resistance, then HRM, then press both click buttons and pair the click.

I’ve not had any issues through ZC app and I have my phone cable tied to the handlebars so it’s very close to the click.

Others have found using a USB extender with Bluetooth dongle gives them best reception.

Hi Steve, thanks for your answers. Unfortunately the option to use ZC as a bridge only applies to PC’s and Apple TV, and I am using an iPad Pro, so the connect screen doesn’t give the option to pair by phone.

Hi

I have a new system and all the updates and firmware

However, I have performed the additional tests

I have the Zwift Hub One, Heartmeter and Click. It is running on a Samsung A6 Lite (new)

I have gone to the pairing screen and ensured that the all devices are paired. (in blue)

The heart meter is hung over the handlebars and I do not touch any of the devices.

Without fail the Click disconnects from the Zwift game device at between 2 minutes 20 seconds to 2 minutes 30 seconds.

No other device disconnects, even the heart monitor which is monitoring nothing.

This leads me to strongly believe that the issue lies squarley with Click.

How is the Bluetooth implemented on this device, does it go into a sleep mode etc.

In my eyes This is either in a firmware or hardware solution.

It will be interesting if other users who have an issue with disconnection of Click have the same issues and timimg in the bluetooth disonnection.

Hi John. My Click connection only lasts a few seconds after the start of a ride before failing. It appears to be getting worse. I have also started to have another REALLY annoying issue:- after a long period of lost connection, the gears will suddenly (and with no input from me) go all the way to either gear 1 or gear 24, then lock up again instantly, making it impossible to ride. Since this issue is clearly happening to a lot of us, why is there no response from anyone on the forum or from Zwift?

Hi Adrian, I am dealing with Zwift support. So it will be interesting.
I think this boils down to Brand protection. Zwift is the No’1 product and they have introduced “The Hub” all the reviews are glowing on the internet ( sponsored ??). If they admit to a problem this could/would damage the brand.

Imagine Apple releasing the original Iphone and your calls kept getting cut off !!!,

This may be a poor production batch or worst case a design flaw. I think Bluetooth interference etc… is a red herring as it is only the click that is affected.

Thank god Tesla’s aren’t connected by Bluetooth
errrr "Have you tried a reset, or silver foiler around your phone whilst connecting to the cars info system as the Bluetooth gamma rays are getting confused " I say that in jest

It would have been good if Zwift had offered the option of a hard-wired connection to the Zwift trainer ( maybe via USB). Then all the connections could have easily been controlled.

I’m new to Zwift and have not been on a ride yet as it is totally impossible to use.

I will keep you posted. But I am popping to the supermarket to buy some silver foil so I can wrap the house , bike , phone , car me and the dog to stop the interference.

Hi John. Let me know if you have any luck with a solution from Zwift. FYI, I first got a Click last October, and it worked faultlessly for a few weeks. Then, out of the blue, it just started failing. After trying numerous suggestions from Zwift, I opened it up to put a new battery in, and a small piece of metal fell out.
To give Zwift their due, they replaced it immediately. Unfortunately the new one began to fail again almost immediately.
I agree with your suggestion about hard-wiring, that would have been such an easy solution. Good luck!

1 Like

I’m having the same issues as Adrian, et al. Have had the hub and click since November or December, and all worked fine until a week or two ago. Click continually loses connection, then rejoins for a little while before losing it again. It seems to only lose connection when I try to shift. I also get the occasional drop to gear 1 or increase to gear 21. The problem also seems to be getting worse. I also have the play controllers, and they shift fine.

Did you buy yours together with your smart trainer? In that,case, can you send it back separately from the rest?

Hi,

I recently bought a zwift hub one with the zwift click, and I have exactly the same problem. I’m using it on a samsung A54 smartphone (Android 14, One UI 6.0). I can connect the zwift hub and the click and update the firmware without any problem, but in game the zwift click disconnects after a few minutes. At first these disconnections were relatively random, sometimes it would simply disconnect, sometimes it would shut down completely and not turn back on for a few minutes (even after a battery change). I thought it was a hardware problem, so I contacted support, who quickly agreed to send me a new one.
While waiting for the new click to arrive, I tried to open the battery compartment and bent the metal contact parts. This solved the problem of the click stopping, but it continued to disconnect from the game, this time almost exactly every two minutes. This can be seen in the games or in the pairing screen of the companion app: here I can see that it stays connected for 2 minutes, disconnects for a few seconds and then reconnects.

To eliminate any possible interference with another device, I tried the same thing away from home and from any other bluetoooth device, the same thing happened on the companion app. However, it seems to work fine on an older Android phone (running Android 12). This seems to indicate a compatibility issue between the zwitf click firmware and my samsung phone. I looked on this forum and reddit, and saw several people having problems on samsung devices, mainly since the end of last year, which coincides with the gradual release of samsung’s new OS One UI 6.0, this could be an explanation?

Yesterday I received my new click from zwift customer support. This time I didn’t update the firmware, and tried to connect it to the companion app on my samsung A54. It seems to work fine and stay connected, although I haven’t had time to try it in games, just in the companion app. I don’t know if the problem is faulty hardware on the first click, or if it’s a compatibility issue with the latest firmware.
I don’t want to try to update it, even though it would give me a definitive answer to the question, I don’t want to risk having the same problem again.
Does anyone know if it’s possible to restore factory settings (and initial firmware) on a zwift click if I try to update it anyway?

Like many other users, I am also encountering the same issues. There are frequent interruptions and it occasionally shifts to either gear 1 or 24.
Everything was working well until recently.

Hardware:

  • Zwift Hub One, newest firmware.
  • Zwift Click, newest firmware
  • Connection over bluetooth
  • Fujitsu Lifebook u7511 Laptop, win11, newest updates

Hi all. This is to update my previous posts on the Zwift Click connection issue. I too deliberately didn’t update the last replacement Click I received, since my problems with the original Click only started after the first update. Could have been a coincidence, but I can’t prove or disprove that. I have been running it now for a couple of months with no problems at all.
I also bent up the battery contact points to ensure good contact, as this is definitely a problem for some Clicks.
Regarding the Bluetooth issue, in the past I tried absolutely everything to ensure there were no problems, none of which made any difference to the Click. I use an iPad Pro, and have now found that I can have it a couple of meters away from the Click with no problems at all.
I hope you have all solved your problems by now, virtual gear shifting is a real game-changer for me.

1 Like

To provide another data point: I had the same Zwift Click problem with intermittent connectivity and phantom shifting on my first use. I switched to pairing through the Companion App and it now works as it should. Very frustrating with a new product, of course, but now it works. I hope this helps those of you who can use the Companion.

Hello everybody,

same exact problems as many here reported.
iPad Air 5th Gen
Zwift Hub One
Zwift Click

All updated to the current software. At first, Click worked perfectly, but for some weeks there are problems every ride. Shifting simply does not work!

Hi everyone

Shuji at Zwift HQ here.

First - the Click will go to sleep to save battery after about 3 minutes of inactivity. If you’ve been riding without shifting for a while - tapping the button once will wake it, and another tap will make the shift. For those who are reporting that pairing is no problem but it doesn’t shift - please make sure this is working.

For those reporting that the Click doesn’t show up during the pairing screen, it is normal for there to be a ~10 second delay after you power on the Click before it’s visible to the game app like below.


Additionally - it’ll take a few seconds for the Bluetooth signal to bond completely, meaning - make sure you wait for the battery level icon and the Connected check mark appears before heading off to the game’s home screen.

There have been a few different bugs over recent months with different root causes. Some have been resolved (most recently with Zwift game version 1.61), others remain open. I’d like to ask the people who reported months ago if the bug fixes we rolled out have worked?

For those reporting in the past month - please provide a little more context as some have, and make sure none of these situations applies to you.

  • What is the LED on the Click doing during the pairing process?
  • When you press either button to power it on - what does the LED do?

Please pair your Click to the Zwift Companion app to check which firmware version is installed. Here’s how. The “most recent version” changes over time, so posting the version number is useful information.

Once done checking the firmware version, please be sure to disconnect the Click from the Companion app. A simple, sure-fire way of doing that is to power off your phone and reboot. It wouldn’t hurt to power cycle the laptop / tablet / phone / Apple TV that runs the main Zwift app either.

Are you pairing your devices and Click “natively” directly to the game app, or are you bridging the Bluetooth signal through the Zwift Companion app? As some people upstream have noted - the Companion app can be useful to identify that you may be having issues with the Bluetooth environment in your room, and this is also a very useful bit of troubleshooting info.

Lastly - if you’re still having issues, please tell us:

  • Is Click visible in the initial pairing screen after waiting a good ~10 - 20 seconds?
  • Click doesn’t make a shift, even though you’ve woken it?
  • Are you in a structured ERG mode workout, or free riding?
  • Which version number of the main Zwift app is installed? Again, “latest” version changes every two weeks as we roll out updates.
  • Which version of the Click firmware is installed?

Hi,
Thanks for the reply.
I had problem with both the zwift app and the companion app, in their latest version at the time of my message (march 7th). The first zwift click I had problem with was running on firmware 1.1. On the second one I received and that is still working to this day, I kept it running on the firmware 1.0
The faulty click was connecting fine on the pairing screen, and worked OK in game for exactly 2 minutes before disconnecting every time. I could reconnect it by going in the menu while in game, but only to have it disconnect it again exactly 2 minutes later. The problem was the same whether I was free riding and using it to change gear, or doing a structured workout and changing the difficulty. I don’t know if you can access and check my work out log and data, but I had this issue on my ride on the 2nd of march as an example.
The problem was also present in the companion app, in the device menu : I could check that my click was connected and up to date, but every 2 minutes it disconnected for a while and automatically reconnected.
None of this problem happened since I use another click with firmware 1.0. Unless I’m sure that the problem was in fact hardware related, or if a new firmware update is announced to fix the problem, I won’t do the update as long as it keep working in game

Hi @Alexis_Saintamand, Thanks for your reply on this thread.

I checked your logs server and compared both logs data (Mar and the most recent logs file)It looks like this was related to the type of connectivity since I noticed some Zwift Protocol error. This might have caused the Zwift Click not to read the signal and caused unstable connections. As long as the device is broadcasting in universal Bluetooth FTMS protocol, Zwift should be able to recognize the signal. Now, even though the Zwift Click is performing well I would recommend updating the latest Zwift Click firmware version ( Version 1.1.0) to avoid running into issues with limited permissions. If you need help on how to do it please, review this article.