Zwift Click issue

Hi. I have tried looking for other Click issues and while some are similar, I was unable to find this exact problem.

The problem: The Zwift Click I received will change gears downward but will not change gears upward.


  • I am very new to Zwift and just set up my Zwift Hub One and the Click this past weekend.
  • I run Zwift on my PC ( AMD Ryzen 5 2600 and RX580 ).
  • The motherboard is an ASUS B450M without Bluetooth or WiFi. I am using a Bluetooth USB plugin.
  • My internet ISP is Google Fiber and my PC is connected directly to my router ( no wifi enabled )
  • The Click is positioned about 24 inches from the Bluetooth plugin but has been as far as 48" away.
  • The hub is closer to 6 feet away.
  • The Click shows as connected to the Zwift program and the battery shows as full.
  • The Click will shift my gears downward ( pressing - )very easily and is working perfectly in that regard.
  • The Click will not shift my gears upward ( pressing + ).
  • Pressing + on the Click does wake up the Click and causes the Zwift program on my PC to pair.
  • Pressing + on the Click does cause the lights to blink in the same way they blink when pressing -
  • The Virtual Shifting in my settings in game show as selected ( on ).

What I have tried:

  • I have shutdown all nearby electronics completely to ensure there was no possible source of interference. This excepts the Hub and my PC of course.
  • I have deleted the knowndevices and pref xml files.
  • I have ensured no other programs were running on my PC that might have somehow captured or interfered with the Bluetooth signal from my Click. Since the only program I have open is Zwift and I have never used Bluetooth through my PC previously, this was easy and very unlikely to be the issue.
  • I have ensured I have a strong internet connection.


  • I have contacted Zwift Support via email. On Monday and Tuesday they asked me to confirm many of the things I mention above. On Tuesday they “escalated” the issue. I have heard nothing else from them.

I am still able to participate on Zwift with ERG mode workouts but it would be nice to have full functionality.

My questions:

  1. Does anyone have any ideas on how to correct this issue?
  2. Does anyone know of another means of shifting gears…it seems like an obvious single point of failure in the Hub One system to plan around but I have not been able to locate keyboard shortcuts to change gears or a way to change gears through the Companion App.
  3. Does anyone know how to directly contact whoever Support would have “escalated” this issue to?
  4. Any other ideas very welcome!

Thank you!

have you set up virtual shifting in your Zwift settings?

I think so. Is there more to do than ensuring it is on?

@Rob_H2 I will add this to my OP. Thank you for pointing it out!

1 Like

Try pairing via the Companion app and see if it works differently from pairing directly to the PC.

There are no keyboard shortcuts for virtual shifting at this time. The Play controllers can also act as a shifter but I don’t have any reason to believe that would work better than what you have. Plus you paid for something that is supposed to work.

Thanks, Paul. I did pair to the Companion App with the Click. No change. I have also tried shutting down the Companion App completely ( including turning off my phone ) to ensure that wasn’t interfering.

The Play controllers can also act as a shifter but I don’t have any reason to believe that would work better than what you have. Plus you paid for something that is supposed to work.

Agree. I was kind of wondering if the foot dragging on just replacing my Click was a play to get me to buy the other controllers but, while I may be an old cynic, I’m not quite that much a cynic. :face_with_raised_eyebrow:

I believe Zwift support is super busy right now handling a flood of new/returning seasonal users and a lot of people experiencing problems with their recently released hardware.

Yes. I got a message from one of their Ambassadors, Billy, that explained as much. (thanks again, Billy) I just find their support process a bit of a head scratcher.

I am really enjoying their product though, even if exclusively in ERG mode. Any complaints on my part are made recognizing the fact that other people out there are patiently waiting for support without the ability to enjoy their purchase at all.

Hi @Jeffrey_Holden, did you manage to get this issue sorted? I have the same problem and it’s so frustrating!! I am at a loss on what else to do.

@Lotty_J , they sent me a new Click and it worked perfectly right out of the box. The person who helped me was Danielle G. but all my contacts were through the email address so I can’t tell you how to contact her directly.

1 Like

Thank you so much! @Jeffrey_Holden at least it’s not something I’m doing wrong!! :grinning:

@Lotty_J I emailed Danielle G a link to the thread and let her know you were experiencing the same issue. Hope it’s as simple a fix for you as it was for me. Good luck.