Zwift Click not working properly

So, my Zwift Click worked fine previously (I have a new Hub One since 2 weeks, with Zwift Click bundled). Today, it started acting up. I did not shift gears when I clicked any of the buttons, but then suddenly after a minute or so, it worked. To stop working again a bit later. I feels like it goes into sleep mode somehow, wakes up to late, works a little and then goes to sleep mode again (rinse and repeat).

What could be going on here? It’s very inconvenient. Gears don’t work when I need them and start working when I don’t need them anymore.

Hi @Fabrice_Algoet

I took a look at the server side reporting for your account and from what I can see the Zwift Click is continuously disconnecting and reconnecting from Zwift. It’s common for the Zwift Click to go into sleep mode after 60 seconds of not receiving any input, this doesn’t seem like that’s the case to me. We will likely need to take a deeper look into this and do some more in-depth troubleshooting for this issue. I recommend writing an email to support@zwift.com so we can better determine what’s occurring here and if the Click needs to be replaced.

1 Like

Did you ever figure this out? I’m having the same issue. It works, I’ll start my workout, and then when I need to use it nothing happens. When I click a button I noticed the led goes blue → green → red then flashes blue then solid blue. Assuming that means it is restarting, the connecting, then connected, but the app has already lost it. I can’t seem to shut it down either.

I think I did.
I switch/wake the Click on/up before I run everything else, so before I start Zwift itself. After that, I make certain everything has the time to connect (Click, Heartrate monitor,…). Haven´t had single problem since.

In before, I only turned the Click on whilst everthing else connected and Zwift booted up already.

I hope this helped.

I removed the battery, cleared the charge, and put the battery back in. Seemed to fix the issue.

Also noticed that if you have Zwift open on two devices and one of them picks up the clicker, then you can’t see it on the other one. So only one active connection at a time.

Hi all. I have had these problems for months. Zwift have been great at sending out replacements, but the problems are recurring.
POSSIBLE SOLUTION:
I was wondering if attaching the Click to the bars tightly was bending it, causing poor battery connection, or even flexing the circuit board. So I carefully bent up the battery contacts (I had to re-solder one when it broke off). I also made a flat base which is cable-tied to the bars. The Click then fits with the usual elastic loops.
I have since tried all three Clicks, and they are all working. Only long-term use will tell, but it’s okay at the moment. Maybe it’s worth a try if you can’t find any other solution.
I’ve attached a pic of my flat base adapter.