Zwift Click Stopped Working

For some reason the Zwift click seems to connect, but the moment I go into a ride I see the arrow that indicates shifting is available for a split second but then it is gone, and I can’t shift. Then I can’t ever get the chance to see it again without leaving the program and coming back in.

It appears to be connected, and the battery says it is still charged.

Hi @Charles_Ackerman warm welcome to the Forums! I’m Norman from Zwift. I sent you an email so please check your inbox whenever you have the chance, we’ll sort this out for you.

Hey… apologies but I must have deleted the email chain where some of this back and forth happened.

So here is where I am at.

I tried to do the firmware update to the zwift click, but at the time the click wouldn’t recognize the need for an update so you guys sent me a new click in the mail (which I was very grateful for). The new click arrived yesterday, and I went through the process to first update to the new firmware.

The firmware is now updated to most recent, and I connected it through the application and tried to set out on a free ride. However, the exact same thing is happening. The system appears like it will allow for shifting for a brief moment and then goes away and I am stuck in 12th gear.

A few other things of note…

  • The other day I was doing an interval workout where the ERG mode was in effect…which is nice because it makes the click not as crucial. However, at one point I stopped pedaling to take a phone call, and I noticed that the ERG mode was canceled and the gears appeared and were functional. And then once ERG was enabled again I realized that I could adjust the percentage of resistance with the click (the 100% readout).
  • This morning after seeing it not work again, I went into the menu and settings of the ride and noticed there was tutorial for the click in there where it asks to you press the button to adjust the gear and percentage… The click seems to work fine in the tutorial.

I am wondering if there is some setting or connection error at this point with the Hub itself… or if it is stuck in some type of ERG mode even in the free ride?

Hi again @Charles_Ackerman thanks for replying in this thread. Shame about these issues, the source needs to be re-evaluated. Because of the nature of what’s going on, it’s better to give you a personalized service.

I sent you a new email so, whenever you have the chance, we’ll be glad to continue working on this for you!