Zwift Click firmware update failed [April, 2024] [SOLVED]

Hello. My Zwift Click is connected to the ZC app. In the ZC the firmware version is displayed as 1.0.0 and i´m unable to update to 1.1.0. Does anyone have the same problem and a solution for it?
The Zwift support isn`t very helpful…

Regards Chris


Hi @Chris_Nomis, welcome to Zwift Forums!

If you’ve attempted to update your Zwift Click firmware and it failed, here in this article are some steps to troubleshoot this specific issue. I’d appreciated to give it a try.

Important: Don’t uninstall and reinstall the Zwift Companion app.

Hi @Martha_C,

I followed the given steps several times. But that is not the problem.
The problem is, that the Companion app “says” the firmware version is 1.0.0 and the version is up to date. But the current version must be 1.1.0 and it is impossible to update the firmware from 1.0.0 to 1.1.0 in the Companion app.

1 Like

I’m also having the same problem ,i believe quite a few people are . unfortunately zwift support just keeps send out the same article on how to update the firmware without actually realising that the companion app is at fault by saying there is no firmware update ,
im send mine back which is such a shame

Hi @Chris_Nomis, thanks for responding! This is Norman from Zwift. I just opened a ticket for you via our support email, please check your inbox. We’ll sort this out for you.

Hey @chris_bennett7, we appreciate your input! Your thoughts about the experience are always heard and implemented so we can prosper in an always improving culture. I noticed we’re working on this for you via a support ticket as well.

If more behaviors like this one are reported about the Zwift Companion App, then we can certainly be sure that something big is wrong. But for now, let’s not worry too much! Your case is being reviewed by the right hands and we’ll soon reach back out to you with a resolution.

I’m running into the same problem. Companion app says firmware is current at 1.0.0 instead of 1.1.0 and does not display the option to update. The Click seems to function fine otherwise, but of course I would like to not run into any bugs if it’s avoidable…

Edit - The next morning, it’s now not working. It’s pairing fine, but button clicks aren’t changing the gears and it’s stuck on gear 12. Kinda frustrating.

Edit #2 - Seems that it works for other devices that I can Zwift on (iPhone, Samsung tablet, and Lenovo desktop PC), but my laptop, a Lenovo IdeaPad, isn’t even recognizing the Click any more. Time to troubleshoot the laptop’s inability to connect while the other devices have no issues.

Edit #3 - Got the Click working with the laptop by enabling it to locate the Click, and I also didn’t realize there was a preference option in-game to allow virtual shifting. Got that sorted and all is working as it should be. Still can’t update the firmware though, so that still needs a fix somehow, but it’s at least usable now.

I have the same problem. Click connects fine to the ZC app, says no firmware update is needed, but it’s still on 1.0.0. Additionally, the Click doesn’t connect to my laptop running Zwift. I assume because the Click is still on 1.0.0.
There are obviously many users with this problem. Sending the same “how to connect” or how to “update” isn’t the issue. The problem, as stated by others, is the Click is stuck on 1.0.0.

I don’t know if your problem with your laptop connecting is the same as mine was, but I had to enable a Bluetooth connection to the Click in Windows itself before it would show up in-game. Then once I toggled the in-game settings for virtual shifting to “on/yes,” it worked just fine, even though I’m also stuck on firmware v1.0.0.

Hope that helps.

Hi. Was this ever resolved. Same problem for me and it feels like it’s specific to iOS.

Mine is on Android, so it’s both IOS and Android problem. Probably the ZC app, in general I’d guess.

I have the same issue. Stuck on firmware 1.0.0 and no way to update on companion. Using a PC with no prior Bluetooth issues, I am getting 1 or two bars of signal strength and it drops out immediately. Will work if I sit the click on top of the wireless antennas


Yea. Tried it on a fourth device and same problem.

Hi all -

Good news - the inability to update firmware on some Click shifters will be fixed in Zwift Companion version 3.57, which releases tomorrow. Thanks for your patience!

1 Like

It’s now “tomorrow” and no sign of an update to 3.57.

probably later on once its been published to the play store or apple store

@David_Rowe3
Please check the Apple or Google app store. Zwift Companion v 3.57 has been released.

Note: it may take a few hours for the release to propagate to Apple / Android servers worldwide.

After the 3.57 update the Click paired and updated fine to 1.1.0, but it isn’t seen when trying to pair with my Zwift on my laptop. When I click the Click button to wake it up, then click the Controls button it just searches and doesn’t find the Click.

Same problem as Larry. Click was 1.0.0. Companion app updated & I was able to update the Click to 1.1.0. At the same time, Zwift updated to 1.64.0. Now the PC won’t detect the Click via bluetooth. Just a never ending search. I’ve changed no other settings.

@Larry_Fletcher_VZT, @Rob_Wickham , can you double check that your Click is not still paired to Zwift Companion by force closing ZC? It may be that your phone is holding onto the connection to your Click and it’s unable to pair to anything else.

I force closed ZC and the PC still just keeps SEARCHING for the Click. I even turned off Bluetooth on my phone just in case it held on to the Click connection somehow. Any other suggestions?