Zwift can't see Elite Direto X

I’ve just signed upto Zwift and have a Direto X, and Samsung S22 Ultra.

I can connect and calibrate the Direto X with the MyETraining app. But when I try to connect with zwift it just keeps searching… never finding the Direto even though I can see it in settings > Bluetooth.

Are there any fixes for this?

Have you tried removing pairing directly to mobile in Bluetooth settings and just pair inside Zwift?

1 Like

I did try that, but it says it can’t pair directly, I need to use an app.

on my w11 computer I didn’t see my direct xr and update usb+ drivers. but buy usb+

1 Like

I’m trying to use it directly with my phone, not my computer.

I’ve done a little research and it looks like the S22 ultra has ant+ built in.
The Zwift app seems to xconfirm this by displaying the bluetooth and Ant+ logos when searching for the Direto X

So for some reason zwift android isn’t seeing the Direto X on either protocol.

Zwift on my laptop works with bluetooth and connnects to the Direto X, but I dont want to use it this way.

Any suggestions?

I’m unsure if the S22 is affected by the same bug, however, the S20 had an update that broke Zwift: Don't update Samsung S20 to Android 13 [December 2022]

If that’s a factor, it’s a show-stopper.

In meantime, at least ensure ANT+ libraries are installed.

  • ANT+ Plugins Service
  • ANT Radio Service
  • ANT+ Plugin Manager Launcher.

Optionally, install ANTtester to see if everything’s working.

Remove the DiretoX entirely from the Elite app. I mean even BLE - make sure it’s “forgotten”. Sometimes trainers are a bit twitchy about being connected to other apps/devices, even over other protocols.

Also have a look at this thread: Pssst: Yes, you do have another device connected, dummy

Thanks, I’ve installed all those. The Ant tester doesnt think the phone has built in Ant+, so I’ve connected a USB Ant+ dongle.

I’ve removed the direto from the elite app and unpaired it.
rebooted the phone
Unfortunately it still cant see the direto x

Do you have any other ANT+ device such as a HRM you can use to test the phone’s ANT+ capability?

Yes I do

I have confirmed the Direto will connect to zwift through a laptop on both Bluetooth and ant

1 Like

I’m not sure what’s going on, but one last thing you could verify is that you have game version 1.33.1. They released a patch to 1.33 that addresses ANT+ problems on PC/Mac/Android.

Yes, I have the latest version.

I’ve just tried another Huwawei phone and it does exactly the same as the S22 ultra.
I can see the direto X in bluetooth devices. But If I open Zwift on the phone nothing appears.

I’ve also tried the companion app, launching zwift on my PC, choosing the companion option on the connection screen and searching for devices. exactly the same.

it must be a bug in Zwift as other training apps work fine.

Still dont have a resolution to this.

I opened a ticket with support, was passed from person to person giving instructions on how to reinstall Zwift on PC, tips for iOS. I dont think they even read the ticket - no help at all.

I’ve tried Zwift on three Android phones - None detect the Direto X
Zwift can see my HR monitor on BT and Ant+
Other training apps can see the Direto X on BT and Ant+
My laptop can see the Direto X in Zwift with a USB Ant+ dongle

Unless I get this working I’ll have to use a different app (any suggestions for good alternatives?)

Any chance that the Direto is paired via BT to some other app, or the operating system, when you are trying to use Zwift? This is a very common reason for the problem you described. I’d start by ensuring that nothing else is communicating with the trainer.

Its a new trainer. I’ve never connected anything to it other than my phone.

PC and other apps connect OK. Its just zwift that cant see it on either BT or ANT+

While Zwift is searching, If I open up settings > bluetooth, I can see the Direto X listed


Is the Directo paired with the phone? If so, UNpair it, restart the phone, and then try pairing only within Zwift. After that, I’m out of ideas.

nope, It wont let me. If I try to pair it gives an error that says you must use an app to pair with this device.

You should go to those settings and forget the trainer.

The trainer should not be connected to any device.

Its not paired in BT devices. Just showing under available.

Can you turn off Bluetooth on your phone and test again?

And the PC is it paired there? can you select it and Remove the device?