Zwift can't control Zumo trainer

Hey there,
Yesterday I got myself a barely used secondhand Elite Zumo trainer. It worked flawlessly yesterday when I tried it out.

However after doing a warmup today, I decided to calibrate the thing in the Elite app, and after doing that I did a calibration in Zwift as well.

Then I got onto my session, and everything seemed off. At first it gave me a ridiculous amount of resistance for a 100 w warmup, then I decided to do for another calibration, and now Zwift doesn’t seem to control the trainer anymore. (I’ve tried it in mywhoosh too, and that didn’t work either)

I can manually change the resistance inside Elite’s desktop app though, so the unit doesn’t seem to be completely broken, it feels like some software issue.

Since I saw a couple of posts about similar issues on this forum I thought I’ll try to get some advice, maybe someone has a working firmware. (mine is version 191)

I’m using a Windows 10 laptop, with Bluetooth connection, I also tried since it on an iPad, an Android phone, even on my Bryton computer. So far no luck. (I could manually change the resistance on the Bryton unit though)

Thank you in advance,

There’s no reason to calibrate it in Zwift. What you did was calibrate in the Elite app and then overwrite that calibration using Zwift. The calibration is saved to the trainer.

Thank you for your response, I didn’t know that at the time, but after that I have tried to recalibrate the thing in the Elite app a couple dozen times, and still, it doesn’t work with Zwift :confused:

You can also try doing a ride using only the Elite app.

I think Elite support is pretty responsive so you should probably talk to them.

I’ve tried that, (at least the flat ride mode, cause that’s free at the moment) I can set the resistance manually in the Elite app, and the trainer responds to that.

Anyway, I’ve opened a ticket with Elite, I hope they will get back to me soon.

I have some trouble with my Zumo to.
Also got firmware 191, please let me know if you get any help from Elite.

Hey there, they responded in a couple of days. They asked me to do a couple of tests, including opening up a service panel, and taking a video of the stepping motor. (it worked fine) they asked me to give them a photo of the serial number sticker, and now they shipped a spare motherboard I’ll need to swap out. It should be here in a couple of days.

1 Like

Oh thanks for fast reply.
I have already changed the motherboard, hopefully it’s just software.

Thx for help!

fre 26 jan. 2024 kl. 22:53 skrev Richárd via Zwift Forums <>:

Well, that doesn’t sound promising :confused:
Let me know if you git it sorted out!

Here is a quick update:
I received a new circuit board from Elite, swapped it out and now everything works as intended!

1 Like