ERG not working (Elite Zumo, Android, bluetooth)


Just bought Elite Zumo and have been trying everything to get ERG mode working (game controls trainer power). I’m able to connecto to the meter with mobile/pad with bluetooth, but resistance does not change accordingly.

If I connect to the trainer with ant+ via Elites own software and control the resistance manually, zwift does seem to get the correct numbers.

Have tried to reboot/reconnect all devices multiple times in different order. Also tried installing the game to pad/mobile. Tried to change all possible settings from Elites own trainer app, but zwift still doesn’t seem to be able to control the resistance. I did successfully update Zumo firmware, without help to this issue.

Whats next, any tips or is this a known problem?

same here - a few others have the same problem too so think it is a problem with the zumo- zwift have said it is an unsupported trainer apparently

Is there a source where Zwift says so?

I specifically bought a trainer to play Zwift, because it looks entertaining (as indoor cycling can be). Made sure everything should work:

:pensive: :poop:

it works on everything except android I believe - if you have a PC and Ant+ you’re good to go

Hi. I had the same problem. I could control the trainer from my Garmin computer and via MyEtrainer app on my android phone. But no resistance on zwift running on my PC. I then bought a cheap ANT+ dongle from china (CYCPLUS). Now I could connect my powermeter and the zumo trainer directly, but I still could not get zwift to control the trainer. I thought that maybe the ANT+ dongle did not have the right functions, so i bought a new ANT+ dongle from Elite. This solved all my problems.