Elite TUO - Zwift not controlling the trainer


I am an Zwift user for months already and everything was perfect till the last update.
The issue is that Zwift seems not to control the resistance of the trainer (at all). It can be clearly seen on climbs where I do not feel the resistance and my wattage goes crazy up (setting the resistance in the app has zero influence on that). It changed around 23.12 (close to the update). I tried various devices, reinstalling etc. - nothing works. Same goes for my wife and her set.

  • Usually I was using Zwift on iPad but also tried android phone and Win10 laptop - same issues
  • Zwift version is the latest one
  • I am using Elite TUO with the latest firmware upgrade. Connected to Zwift via Bluetooth (never experienced any connectivity issues though)
  • I am located in Poland

Looking forward to any suggestions how to solve that as it really is quite frustrating at this stage.
Thank you.

What happens if you try riding with the Elite myETraining app, does it control resistance then?

Hi Steve, when using myETraining it does control the resistance so my guess is that this is not a hardware issue with TUO.

Are you sure that the controllable device is paired ok?

Seems so - TUO is recognized and the pairing screen looks fine.
(please check the screenshot: https:// prnt.sc/wd2wpd)

That certainly looks right.

In myETraining, is that in ERG mode or SIM mode that it was working ok? And have you tried a workout in Zwift in ERG mode?

Tried ERG mode in myETraining just now and it is not maintaining the resistance ( :dizzy_face:).
Will check with Zwift later but right now it actually seems as an hardware issue. I also opened a ticket with Elite support sending them all the logs.

Ok, so it really seems like an hardware issue. ERG modes in Zwift/myETraining do not work. I guess it might be something with the power sensor as myETraining is not able to find and connect to it (printscreen: https:// prnt.sc/wd7dc5).
What is more I think that the noise which TUO is generating when ,adjusting" is different that when everything worked properly.

It sounds like you should speak to Elite support.