Zwift Calibration problems with Elite Suito

Hi Guys,

I have been unable to run the calibration on Zwift with my new Elite Suito except the first time I tried it.

I run the calibration option and as you know, it will tell you to go up to 37kph and then say keep the speed and I am at it for 10 minutes or more and I don’t get the instruction to stop and allow spin down. So I end up cancelling the calibration.

The first and only time I was able to calibrate, writhing less then a minute of hitting the 37kph, I got the instruction to allow spin down and calibration was successful.

I did email Zwift and was told to check if my Suito program (with Elite Upgrado app) was the latest and it is.

I then emailed again Zwift for help and I was told to try and use Elite my Etraining app to calibrate but then I seems like I would have to make an paid account for this.

Anyone has experienced the same problem? Anyone has any suggestions?

Thank you,

Fernando

It’s always recommended to use the manufacturers app for calibration. That app should be free. They might also have a paid app but you shouldn’t need that one.

DC rainmaker says “And technically, there are two apps here. The first is their Elite MyE-Training app, which you can do calibrations from within:

And then there’s the new Elite Upgrado app – which actually launched on the Elite Suito a bit over a month ago. This allows you to do firmware updates of the trainer (oddly something relatively new to Elite). Simply crack it open and let it search for nearby trainers:”

2 Likes

Thanks for the help Ben.

I was finally able to calibrate the Elite Suito using the E Performance app of Elite. Took a bit of looking
where to go. I was able to also set my tire circumference which has that option in the elite app.

Didn’t notice if Zwift has that option to set it up.

It also came back with an offset of 10048 . Not sure what this means for a bike trainer as this Elite Suito is my first one. So I am still learning as I go.

Cheers!

Fernando

Fernando, underneath the trainer is a sticker with it’s original calibration number on. Your calibration figure should be somewhere in the same ballpark.

Does it seem OK now? Mine went back after just one ride because it was obviously faulty.

Thanks! I looked underneath the trainer and saw of course the serial number and the code (not sure what the code is. Then a number printer on a separate sticker 48_19 and then another one written in a sticker that has Elite #1 9384

Not sure which is the original off set but doesn’t match the offset number that came out when I did my calibration.

Would you know which one would be the original offset ?

Thanks,

Fernando

It will not match, but should be somewhere near. It is the 5 figure number on the sticker. My advice, warm the trainer up for 10 minutes and do the calibration test - this makes a HUGE difference. Let us know what you get.

1 Like

Thanks! I will try that out.

I emailed Elite and wanted to share what their customer service said.

I asked them which one was the number because there is no 5 digit sticker underneath the trainer. There were only 6 digit ones.

This is from Elite

“ Concerning your request:
The offset value that you obtain at the end of the spindown is the time in ms that the Suito need to stop from the spindown,
In your case the difference is about 1 second and it is completely normal

In any case the spindown value doesn’t have to be compared at all with the default value
The spindown value is needed only for assistance porpoises

Once obtain the spindown value it means the calibration has been done correctly and nothing else need to be done”

So I guess I’m all good. Thanks for your help.

Cheers

Hi everyone, I’ve been having an absolute nightmare with my Suito and wondering if it’s all down to the calibration. I’ve been trying to calibrate using Elite’s My E Training app and it asks me to cycle at 58mph/93km/h - surely that’s not right?! In any case, even if I get close to that the calibration fails. Riding on Zwift feels unnecessarily hard even though I’ve got all difficulty setting switched to off. It looks like the firmware of the Suito is up to date but the calibration doesn’t seem to be working for me. Any ideas?

I don’t have that problem using My E Training for calibration. Seems strange. Maybe best to email Elite. They were pretty responsive .

The myETraining app won’t calibrate my suito either, do you use the app for rides then calibrate?

No. I use Zwift to ride and then calibrate with my E Training .

Did you go through settings and press training calibration? You need have warmed/used your trainer for at least 10 minutes before you do calibrate .

I usually would do the calibration after my usual Zwift ride

I’ve tried again this morning and got some really weird readouts for calibration. It was asking me to go at 58mph!!! The offset number I got was 9609 and I honestly don’t know anything about the offset number and can’t find a sticker on the Suito which says what the offset number should be. Seems really odd to ask me to pedal at 58mph for calibration - even a mega fit cyclist is lucky to get 30mph! I’m on the latest firmware. I have to disconnect and reconnect the plug to get Bluetooth signal on my Mac. I don’t know what else to do with it other than send it back at this point.

I have the same problem. After I warmep up for 10min I started the Elite App. The app asked me to ride 30km/h. After 30sec the app said “Calibration unsuccessfull”. I repeated the test three times. The same result… .

They must be having some software glitch because after reading all the comments here, I tried to do a calibration today and it said the same thing. “Speed up to 30.1kph “ then I was getting “calibration failed”.

I emailed elite customer service. Told them the problems and copied and pasted your comments as well (hope that was ok).

I will keep you guys posted when they reply back to me

It is a software glitch in Zwift. Spin over 45km/h or even more :slightly_smiling_face:

Haven’t tried that yet on Zwift. Something to try. Thanks

Just received email back from Elite. Although I have yet to try their suggestion, I have copied and pasted it here for you to see

“ Concerning your request:
Please try the following:
Update My E-Training app on your smartphone/tablet or install it
If not yet done configure the trainer and be sure you set as circumference the real wheel bike circumference

From Training go to Level mode
Clic on Start and pedal for 1-2 minutes and then check all again

Then do again the calibration and be sure you speed up and overpass the target speed and you continue to speed up till the stop pedaling message appears

Please let me know the result
Regards

Andrea B.
Elite srl”

Hi guys,

Just an update. I followed the instruction from Elite as mentioned and I was able to calibrate my elite Suito trainer.

I did the additional step and run if for 2 minutes on level mode then I run the calibration.

You don’t need a paid account for level mode.

See below from elite

“Yes, Level Mode can be used even if you don’t have any active subscription

We do not know if Zwift calibration is compatible with Suito so please calibrate the trainer by using My E-Training”

Also note what they mention about calibrating with Zwift.

Hope this helps and you guys have now been able to calibrate your suito trainers

1 Like

Had the same issue like Finn yesterday after connecting my new wahoo elemnt roam to my suito. After trying different things to re calibrate I found your suggestion and it worked.

Thanks a lot! Now I can complete my Christmas challenge.

Tried to connect the roam to my suito again at the end of my ride and the problem appeared again, even with the elemnt in passive mode.

Looks like the wahoo causes the problem, so I will not use it for indoors anymore.

Happy holiday everyone!

1 Like