Zwift App will not launch on Macbook [Oct 2021] [1.18.1] [SOLVED]

scusate ma noi stiamo ancora aspettando
sorry but we are still waiting

you can tell the steps

let’s wait

Same issue here with a Mac mini (late 2012) since updated to Catalina Version 10.15.7

Still waiting for a fix!

This post / conversation about the Macbook Pro & Zwift Issue started 11 days ago, no solutions yet from Zwift, how is possible? My laptop is working perfect, the only issue is with this paid application, 15 usd per month sounds like a reasonable price and time for this would have already been fixed.
“Try using the application with another device” is not the response expected from Zwift, we will receive any compensation for this @shooj ?

Is there another way to escalate this somehow?

Share this with Zwift if there’s a solution please …

I have been emailing Zwift support, they give the standard out of the box replies, but if everyone starts emailing them, something might get done!

support@gozwift.mail.kustomerapp.com

Hey everyone - thanks for your patience while we sorted out this bug. Version 1.18.2 (1.0.87337) for MacOS has released. Please update at your earliest convenience.

2 Likes

It took a while to download… but, still not working. The same thing.

When I go to ‘About Zwift’, it says‘Version 1.0(25)’

JohnW

Correct- this is still not working

That didn’t work!

Hi there!

Would you kindly try uninstalling and reinstalling? Just as a basic troubleshooting first step.

Thank you a million in advance!

I did… twice. No good.

JohnW

1 Like

same issues, have just uninstalled and re-installed twice, now zwift saying version 1.0(25) still not fixed, this is killing me

Unfortunately this fix did not work for me either. I am running macOS Catalina 10.15.7 with all the latest security updates on a mid 2012 13-inch MacBook Pro (which still runs brilliantly with an SSD drive). Zwift is updated to 1.0.87337 and the launcher is 1.0.25. The app crashes and quits when I click on “Let’s go”. I gave Zwift full disk access from the system preferences.

Procedure I have used to update Zwift:

  • Deleted Zwift app from the Applications folder
  • Deleted the Zwift folder under Documents
  • Deleted the Zwift folder under Library/Application Support
  • Emptied Trash Bin
  • Downloaded Zwift which downloaded the app update on first start

The Zwift logs look normal but this error is logged in system.log:

Nov 9 07:31:43 mymacname com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.ZwiftApp.639): Failed to bootstrap path: path = /Users/myusername/Library/Application Support/Zwift/ZwiftApp, error = 2: No such file or directory

The file /Library/Application Support/Zwift/ZwiftApp is actually there. If I double click on this file it opens a Terminal window and this what it logs:

myusername@mymacname ~ % /Users/myusername/Library/Application\ Support/Zwift/ZwiftApp ; exit;
Changing working directory to /Users/myusername/Library/Application Support/ZwiftOpen assets/global.wad in file 0x058eab28
 compressed size   = 3480763
 decompressed size = 10520800
Interleave mode: Loading / Decompressing WAD...  0% 
 46% 
 61% 
 76% 
 91% 
100% 
 Done!
Close file 0x058eab28
Open assets/Environment/Ground/textures.wad in file 0x058eab28
 compressed size   = 6427061
 decompressed size = 6999314
Interleave mode: Loading / Decompressing WAD...  0% 
 25% 
 33% 
 41% 
 49% 
 58% 
 66% 
 74% 
 82% 
 90% 
 98% 
100% 
 Done!
Close file 0x058eab28
Open assets/UI/WhiteOrangeTheme/WhiteOrangeTheme.wad in file 0x058eab28
 compressed size   = 1841466
 decompressed size = 11996754
Interleave mode: Loading / Decompressing WAD...  0% 
 86% 
100% 
 Done!
Close file 0x058eab28
Open assets/UI/minimap/minimap.wad in file 0x058eab28
 compressed size   = 138865
 decompressed size = 1314514
Interleave mode: Loading / Decompressing WAD...  0% 
 Done!
Close file 0x058eab28
Open assets/UI/WhiteOrangeTheme/Scotty/Scotty.wad in file 0x058eab28
 compressed size   = 246800
 decompressed size = 3069778
Interleave mode: Loading / Decompressing WAD...  0% 
 Done!
Close file 0x058eab28
Open assets/UI/layouts/layouts.wad in file 0x058eab28
 compressed size   = 24099
 decompressed size = 71691
Interleave mode: Loading / Decompressing WAD...  0% 
 Done!
Close file 0x058eab28
Open assets/Environment/GrassTextures/GrassTextures.wad in file 0x058eab28
 compressed size   = 92691
 decompressed size = 707442
Interleave mode: Loading / Decompressing WAD...  0% 
 Done!
Close file 0x058eab28
2021-11-09T08:04:35> [INFO] CNL 3.13.0
2021-11-09T08:04:35> [INFO] Machine Id: 2-8e924917-b1ff-40b8-a2bd-65679132dc5b
2021-11-09T08:04:35> [INFO] CNL initialized
Open assets/fonts/font.wad in file 0x058eab28
 compressed size   = 191425
 decompressed size = 620412
Interleave mode: Loading / Decompressing WAD...  0% 
 Done!
Close file 0x058eab28
[593:7058:20211109,080435.771976:WARNING process_memory_mac.cc:93] mach_vm_read(0x7ffeeb94f000, 0x2000): (os/kern) invalid address (1)
zsh: abort      /Users/myusername/Library/Application\ Support/Zwift/ZwiftApp

@Alyssa @Lindsay_Ruppert

1 Like

I have reinstalled the program and is still having issues starting it on Mac pro mid 2012 with Catalina.

1 Like

Same here…

it updated and it’s still crashing when I hit the LET’S GO button!

Please sort this out…

Thanks

@Anti-wtrl @Eric_Lindqvist @Enguerrand_Detervill can you open the Console app, select system.log and check whether you get a message along these lines too?

Nov 9 07:31:43 mymacname com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.ZwiftApp.639): Failed to bootstrap path: path = /Users/myusername/Library/Application Support/Zwift/ZwiftApp, error = 2: No such file or directory

1 Like