Zwift app does not launch win7 does not launch

Zwift worked fine on my Laptop with windows 7 SP1 64 bits for weeks.
It is a payed subscription of Zwift.
Right now, for 2 days, when i want to start up Zwift nothing happens after clicking the “Let’s Go” button. Only a few screen shots appear of Zwift and than the app stops working.
Already tried:

  • uninstall the zwift app, starting up the laptop again and reinstall Zwift. Same result every time.
  • reset MS explorer internet settings. Same result every time.

The specs of my laptop are sufficient for Zwift, they are:
Intel Core i5-6300 CPU@2,4Ghz and 8Gb memory on a 64 bits controlsystem windows 7 SP1

What can i do more?

Disable any anti virus and try right clicking on the icon and running as administrator.

I would also suggest upgrading to Win10 since Win7 is no longer supported by Microsoft.

Hi @Marius_Van_Rijckevor welcome to Zwift forums.
Those symptoms sound like the Launcher app is not finding the correct folder location for the game app. This can happen if files get corrrupted. Uninstalling / reinstalling may not remove the corruptions. So instead, try this:

I have posted two suggestions in this previous thread. Would you try the procedures in both of my responses?

Please let us know how it worked out?

1 Like