Zwift App Crash shortly after Event starts [March 2022] [1.23.0]

Just happened to me. Disconnect messages, then completely crashed my computer 8 miles from the state finish. So glad I bothered joining :roll_eyes:

Same happened to me, but a few miles from the finish. Incredibly irritating.

Hi Kevin,

I think this is unrelated to the problem you have been having. If you get in touch with the support team with your game logs, they may be able to help.

We have a workaround in place (spoiler, it wasn’t to turn off powerups) which should cover all existing events until we have a solid fix in place.

1 Like

Hi guys, I am getting some crashes when I clicked on “join event” from a free ride. This doesn’t happen at the time and also started after the recent update. Any one has the same issue?

Lots of reports starting to roll in about this. An anticipated timeline for a fix would be appreciated, especially with the time-constrained ToW going on and people being unable to take part.

Thank you.

1 Like

Two crashes in two weeks. The first during a workout session on Alpe du Zwift and the second one on the latest race this morning on ToW 2. I noticed my drops touched 200.000 and after the crash they are sub 200000 again. Both crashes after approx. 40 minutes halfway into the workout/ tour. I am using MacOS (12.3). I can live with an occasional crash as long as I am not Everesting;-)

Just crashed 2 minutes into TOW Stage 3. Running Windows 10, Zwift Launcher 1.1.2 and game version 1.23.1. This was also the first time I got the new homescreen. I don’t know if it could be related.

Installed the new update for this week (3/16/22), on my Windows pc. Today, when I attempted to either ride a workout or a free ride, Zwift would start up OK, connect the sensors, give me the new interface screen permit me to select a workout or free ride, and route. However, within 5 seconds of starting the ride (avatar appearing and moving), Zwift would crash. I attempted to start my ride at least 12 time, with the same result each time. In nearly 3 years on Zwift, this is the very FIRST time that this has occurred. It appears that there may be a fatal bug in the new update. This was not during an event, but was both free-ride and workout!

I just tried joining the TOW Stage 3 an hour later and crashed again 1.4km in. Emailed support with even more event viewer logs. I hope they’re useful.

Similar but on W11 - I’ve tried TOW Stage 3 twice today and both times Zwift hung at exactly 2 minutes and 12 seconds into the event.

Hi, 2 times zwift freezes during 2 different Tow stages. Had to force shutdown and reboot. Late join was possible. Very frustrating. Windows 11 PC

UPDATE: Zwift game version 1.23.2 fixes this bug, and is live.

Please update your game at your earliest convenience. It may take several hours for this version to progpage to Apple App Store and Google Play Store.

2 Likes

Zwift has crashed more for me in the last 2 days than the entire 4 years I have been on it combined.
Always “zwift not responding”

1 Like

The fix seems to specifically indicate that it is for events that don’t have power ups. Does this also address crashes within TOW events as they still have power ups and it’s where a lot of crashes seem to be occurring.

Apparently not.

This thread seems to be a big mixture of crashes in events with powerups disabled, and other unrelated crashes in events like ToW that do have powerups.

there is something wrong with the windows installer, its not installing a critical windows component it needs

the game will not even run on my i5 10gen laptop anymore

This happened to me in stage 3 on Downtown Titans just before the final KOM literally about 2 meters before the banner, this was on the last day of stage 3, it happened again yesterday in stage 4 frozes and crased just before hitting thebnew loop after the lead-in. I updated to the latest version of Zwift before doing stage 3, this is a new bug for me since that update, ive been lucky and never suffered any issues with Zwift especially anything this big.

My PC spec:

OS: Windows 10 Pro 64-bit
Storage: 256GB SSD
CPU: Intel Core i7-3770 @ 3.4GHz (4 cores 8 threads)
RAM: 8GB Team Elite Dual Channel DDR3
Graphics Card: Nvidia GT710 (not the best but works fine)
Internet Connection: Wired 600mbps

Thanks

Updated to version 1.23.3 before joining the Tour of Watopia, stage 5, Group A, 4 pm EST USA, Saturday. Zwift froze at exactly 8.9 km from the start.
Decided to do it again at 5 pm, so I restarted the computer, just in case. Started the event, and surprise, it froze again, EXACTLY at the same place, 8.9 km into the event.
I have a good PC, good processor, more than enough RAM and memory, good AMD graphics card, good connection.
The fact that it froze at exactly the same location would indicate that the problem has to be in zwift, maybe it is a problem in the last update? Last day I used zwift was on Tuesday, everything was fine.

1 Like