zPower option not active

Hi guys,

I recently joined Zwift, using a dumb trainer (Elite Crono fluid - see photo) and Polar speed and cadence sensors. It appears that my displayed Wattage is very high, and in the setup menu I cannot select zPower as an option (it is grey - inactive) and only classical power is available. Any idea how I can activate the zPower option?

From what I remember zPower and classic power are determined by Zwift and what trainer you select in the pairing menu. Not sure if you have seen these links but they might provide some useful information to dial in your setup to more realistic figures:

Awesome, thanks a lot for your quick response!

One thing that people sometimes do is try some of the other trainers from the menu to see if they can find a more realistic power number. But if you don’t have anything to base this guess off it’s a bit hard.