ZP Activities list on profile

Hi everyone,
I’m new to the forum, been on ZP a little while.but only just starting to get to know my way around it. I was looking st my Activities part of my personal profile and for some reason every activity gets listed up until 27th November 2020, then nothing apart from one ride on the 10th January 2021. Everything is showing on Companion correctly and uploads to ny Strava, plus the group events show on my profile too…but why is it missing from the Activities tab? I donf believe I’ve done anything to my settings, I’ve checked husbands account and his has all his sctivies showing so it appears as a blip on mine. Any suggestion on how to remedy this and/or get future rides to show up on this section?
Many thanks in advance, Donna

Hi Donna - have you tried the “Update Activity List” button on the Activities page?

Hi Dean,

Yes, I did. I’ve done it a few times but nothing additional comes over. I just can’t work it out. Everything is showing up on the Courses page when I do events for instance and its all on ZC/Strava. But nothing on Activities page?

I did a search in the Zwiftpower forums and whilst I find a few posts with the same symptoms, all reference privacy settings.

I then went to check your activities on the companion app and it shows “This Zwifter has no activities” which I know isnt true so I then looked at your activities under your profile and note that most from beginning Dec are private (they have green lightning bolt next to them - non-private are blue lightning bolts).

So I think the problem is related to your privacy settings either at activity or account level.

From posts on ZP, even if you changed the settings now, they wont retrospectively apply unfortunately. But you could try and change privacy settings then hit the Update button and x fingers.

So your next activity, make sure its not private and that your privacy settings settings are open on Zwift (if you dont mind others looking that is).

Yes! I think you might well be on the money there - I did change my settings to ‘followers’ a little while ago (must have changed one back to ‘all’ though mid Jan) so am pretty sure you have nailed it. I will change it to ‘all’ for my ride later and check but thank you so much, it was starting to irritate me haha :grinning_face_with_smiling_eyes:

1 Like

Tested…and…it worked! Yay, thank you so much for taking the time out of your day to help me, much appreciated :blush:

Glad you got it sorted Donna :smiley: