Activities Tab on Companion App

Hello and thanks for the help in advance!

I use the companion App and I noticed something strange. If I go to the activities Tab on the main page I can see all my activities. But if I chose my profile page and then select the activities Tab i can only see a few activities, since February that my activities are not loading. Can i change this? I cant seem to find any info of this particular bug.


Have you tried clicking on the “update activity list” button?

I’m sorry but I cant find that option on the Companion App.
I’ve turned the APP upside down but i cant seem to find any solution. Help please!

I have checked my Zwift profile on the web and the list is complete.

Sorry! I had totally read this as a Zwiftpower issue!

This sounds really strange and is working fine for me when using ZCA. It isn’t something I’ve seen reports of before.

I take it you have the latest version?

I was able to scroll all the way back to my first activity on Dec. 25th 2018.

I have the latest version of the Companion App.

The last activity I can see on tua App dates back to February 2021 which os completely Impossible. I take part in all kinds of activities on Zwift every week.

Speaking of zwiftpower, even with the “update activity list” my last activity listed is May 2021.

Something’ s wrong with my accounts sync

The problem isnt with older activities but rather with the recent ones. They are not syncing properly I believe

I just tried the ZCA and my activities are listed correctly.
Where are you seeing an “activities tab”?
I’m not sure I could solve your issue but I could help determine if it is wide spread.

I can only see your activities up to that date too. I see this when helping people troubleshoot ZP issues with events when they have accidently turned event privacy on but kept profile open. It would be strange that this is the issue given you can see them listed under the main pages “activities” and not your profile “activities”, but worth checking.

My android is fine too btw but if its data corruption, clear your cache, remove the app, restart phone and install CA again.

Thanks for the tips.

So I cleaned the cache, uninstalled Companion App, restarted phone, reinstalled the APP and its the same.

Ana I also went to ZP and did “update activity list” and the last one there is from July.

I don’t get what the problem is…

And did you check the privacy setting on some recent events?

I just configured a ride I did yesterday to Private and it wont show on my Activities under the profile but does show under Activities in opening page …same symptoms you are describing. I unchecked the event privacy and its back.

I would try that but I cant seem to find where I change those settings. Can you help me with instructions? Thanks in advance

Sure …

Firstly, on your phone go the Settings via the menu button on front screen (hamburger).

  • Scroll down to Settings
  • Goto / Tap Privacy
  • Turn Activity Privacy to Public (if it isnt already).

Then back to Home screen.

  • Tap on “Activities” in home screen screen

  • scroll down to say your most recent activity

  • Click on that activity

  • In top right you will see an edit button (circled below)

  • Then in the next screen, make sure activity is Public like this pic…

  • Save it, and it should now appear in your Profile activity list.

Note that once an activity is public, you will now be able to import in ZP once you Update Activities again (ZP will only import Public activities).

Dean, thank you so much for all tour help.

I’ve tested changing my December activities and they now appear on my profile page and on ZP as well.

I would never figure this out by myself so thank you very much for your help and Patience!

Ride On!


Thats goods news, and yes, I can see them too! Cheers.