Zc problems

Hello. I have a problem with ZC. The ZC application and the zwift application are connected to each other, but I do not get data from the smart trainer and the heart rate. Everything worked normally until Monday, February 28, but not now. Please help, thank you very much.

Please provide more information about your setup, such as what sort of trainer, power meter, HRM, etc. you are using and how you are connecting.

I am connecting via ZC since this option exists. I have Direto xr-t and I use Garmin venue2 to monitor my heart rate.

On the pairing screen in the game there is a gear icon in the upper right corner, that is where you can choose between using the companion app as a bridge or the built in bluetooth, make sure you have the correct setting chosen there.

I know this option because I always use ZC thanks

have you tried to pair directly with your device rather than using the companion app? Also, what device do you use to run the game? Apple TV, PC, MAC, iPhone, etc…?

I tried to connect everything via Ant + key and it worked, but I prefer to use ZC because everything is more reliable. I use a laptop to play zwift

1 Like

Each environment is different, I find ANT+ to be much more reliable where I am. Something must be interfering with the bluetooth or wifi signal. Sometimes a reboot of your wifi router/modem will help?

The only thing I haven’t tried is to turn the router off and on again. I don’t know if it will matter.:thinking:

You may also want to force it to use a channel such as 1 , 2, or 3 as they seem to be less utilized by other frequencies.

I will do a little more research and if I fix it I will post. Thanks for the help👍

I am having the same issue discussed here. I am using Zwift Companion with Apple TV. Have had no issues until today - rode yesterday with no issues.

When I open the companion app, it tries to put me directly into a world. I have to end my “ride” even though I am doing nothing. However, I can end this ride through the companion app with no issues, so I know that the companion app and Zwift are communicating.

I have tried connecting my smart trainer (KICKR Core) directly to Apple TV using Bluetooth, and it finds it. Same with steering device. Only when using the companion app, it acts as if it can’t find the Bluetooth connections.

I have reset my router, uninstalled and reinstalled the companion app on my tablet, unplugged and reconnected my trainer, cleared the cache on Apple TV, and even uninstalled and reinstalled Zwift on Apple TV. All with no success.

Very frustrating, because as I said, I just rode yesterday with no issues.

And to add to the confusion, the companion app works and connects properly on my phone - a Samsung Galaxy S21. It looks as if the problem is when I try to use it on my tablet - a Samsung Tab A7. However, this was the way that I connected yesterday when I rode.

They will have to fix it because I think we are not the only ones with these problems. Ant + works for me but I don’t trust the key because it has a lot of problems, it doesn’t respond very quickly and often disconnects