Zwift Companion App not recognizing trainer/work out


I’m a long time Zwifter & have been connecting my Elite Direto trainer to my Apple TV via my Zwift Companion app. However, today, I went to try to ride and the Companion app is not recognizing/connecting with the Zwift app on Apple TV. Anyone else have this issue today? I checked and my Bluetooth is on. I can manually pair my trainer with the Zwift app on Apple TV by deselecting “Pair with Zwift Companion”. When I start biking using this connection, the Zwift Companion app still doesn’t recognize that I’m moving; it will not show me the map or any in-game features. Thus far, I have tried restarting everything (phone, Apple TV) and reinstalling the Zwift Companion app on my phone. Any help or insight would be much appreciated. It’s a bummer because I was looking forward to getting credit for my ride and using my HR monitor (which pairs with the Zwift Companion app).
Thanks in advance!

Hi @Brianna_Brotherton, welcome to the forums. Check to make sure your phone is on the same wifi network as the Apple TV. Sounds like they aren’t communicating, and must be on the same network to do so.

I have reported (via Twitter) a similar problem (all my stuff is definitely on the same wifi network).

1 Like

If one is on the 5ghz wifi band and the other is on the 2.4ghz then they won’t communicate, make sure this isn’t the issue.

That’s not necessarily true.

What’s critical is whether the Zwift Companion device and the Zwift client device can talk to each other on the home network. With some routers the 2.4 GHz and 5 GHz networks will be able to talk to each other fine, and others not.

1 Like

Only one frequency here and it has worked fine for the last year.

1 Like

Try rebooting the router.

Same as GL_Pinxit above. Same WiFi networks and it’s worked fine over the last year or so. It seems to be an issue with the Companion app, since even when I ride using Bluetooth to connect my trainer, the app doesn’t recognize that I’m “in-game” (e.g., I can’t give anyone a thumbs up or change the Bias % on Training rides). Next steps if rebooting router doesn’t work?

FWIW, I tried again today and am still having the same issue.

1 Like

It’s not an issue with the Companion app. Even if your phone is connected to the trainer via Bluetooth, that doesn’t help - the Companion app’s device needs to be able to see the Zwift client app device over the local network (wifi) - not over BT.

Same issue for last month or so after an update. Lots of drops and will no longer recognize Wahoo Ticker. Been using AppleTV for a year and was fine until recently. And yes everything is on the same network.

I have had this, tried to stop phone data, tried all sorts, but nothing works.
I have come to it that restarting my router everyday is the only solution.

My internet works perfect from home so I have come to it it’s a Companion App or Zwift issue.

I have exactly this too. It is ridiculous to have to restart the router before zwifting and also very disruptive. Everything else using our wifi works perfectly without having to do this (including various enhanced security things) and it previously worked seamlessly for a year before this new issue suddenly arose. And the Zwift customer service model is ‘we don’t care’.

In this case, Zwift support can’t help you, because the problem is in your local area network at home, i.e. your router and any other associated equipment. That’s outside of Zwift’s control.

No, you shouldn’t have to reboot your router, but something is clearly wrong with your home networking setup (possibly the router itself, but could be some sort or parental controls issue).

Thanks. My home setup is unchanged and worked fine (as in ‘perfectly’) for the past year. Everything else in the house that uses the same router is also running fine (as in ‘without restarting the router’). The only problem is when running Zwift and as it is a new problem this points to the problem being with Zwift.

1 Like

Or a new networking problem having developed that only affects Zwift.

Something is stopping your ZC device from seeing your Zwift app device on your LAN.