"your last ride didn't save" message

This has happened for about a month now - which is about 20-30 rides. When I’m done with a ride, I back out screen by screen and click on the “Save” when I see it - and I give the program enough time to do so. Then the next ride, I get a pop up message that says “your last workout didn’t save. Would you like to save it now?” (Words aren’t exact as I’m going from memory). I click Yes, and then see my avatar in the grass in Watopia next to the road. I back out a couple of screens and then everything is fine. But, I’m getting this every time now. I even backed out of Zwift and searched for the App and it didn’t look like there were any new updates, either. The first 8 months on Zwift worked flawlessly.
Apple TV 4k
Concept 2 Bike erg

When saving a ride, you want to ensure that you first select “menu” on the bottom left, then “end ride.” After that,ensure that you type in your activity title, and then click “save and exit.”

I’d encourage you to submit a support ticket with us if you continue to have trouble. We’d be glad to help!

I still get the “did not save” error message every other or every few rides. Since it’s been happening for a year (?) so far without other ill effects, it’s something that I can live with. But, when it happens again, would you want me to submit a ticket? And if so, what precisely would you need from me? Screenshots?

At the end of each ride, I select “menu”, then “end ride”, then wait for the countdown timer to drop away, then “save”, then I back out of Zwift with the menu button on the Apple TV remote.