Workout/Plans window crashing on AppleTv4k


(Eiki Egilz) #1

Decided to create a seperate thread for this issue, instead of embedding it into the remote control bug of AppleTv:

Now I have a new problem only with the Workout/Plans window …
I simply can’t use it any more !!! Before it was bad, now it’s even worse. I changed to 720p on my 4k Samsung TV, trying to get the remote control in order … didn’t help at all. So now when I’ve changed back to 4k resolution ( both tried 50 and 60 Hz ) and now the Workout/Plan window is inaccessible !!! Both in 4k resolution, and 720p resolution. I even tried uninstalling and re-installing Zwift to fix the issue. Please see the video … I’ve also restarted the AppleTv4k five times, and flipping the resolution back and forth … it always crashes at this same dialog, please see the attached Youtube videos I’ve created

4 videos below clearly show this dialog … please see video #3 which explains the CRASH bug:

This video shows that this is once again, connected to the remote control … and it’s ONLY this Workout/Plans dialog which acts like this, just CRASHES!


(Vincent) #2

Hey Eiki, thank you for the heads up as usual! This crash should be fixed on the newest Apple TV 4K update 1.0.33010. It looks like last time you logged on through Apple TV you were on the last update, can you try updating and see if the crash is still happening?


(Eiki Egilz) #3

Hi @Vincent_Williams1

As I posted on the Facebook group Zwift Runners:

Lindsay Ruppert I just put this to the test … and it’s a great success - this bug has been fixed! Kudos to you guys for that! But fixing this had some negative side effects since we lost two categories of training.

Please have a look at FB to see the full details - would be nice to get back the two missing categories - maybe you can add that as a feature request for us AppleTv users?