Workout mode target cadence not consistent with Companion

Hi, probably just me but I was doing Workout #1 today but the computer was telling me to spin at 90rpm and the Companion app pestering me to spin at 105rpm. Only by spinning at 100rpm would everything be happy, so I was between a rock and a hard place!

Tried restarting the Companion App but it didn’t make a difference.

6 Likes

Hi @Matt_Roots welcome to Zwift forums.

I split your question off to its own topic because this sounds like a bug unrelated to Zwift Academy. I’ve started a trouble ticket for our team to try and reproduce.

Not sure I have a great workaround to suggest in the meantime. Maybe not pair up Companion during workout modes? I know that’s not a great answer, but your workouts shouldn’t have this cadence conflict.

Hello, I also did the very first ZA workout #1 with a group today, and had the same cadence issue. I was able to ignore that issue (also tried restarting Zwift companion) but my avatar had such troubles with this workout it ruined the effort. First off I wasn’t taken to the start until after everyone had taken off. Second, the speed surely was off. Working hard on the flats at 14 miles/hr…? Third, I was “locked in” together with another late comer, and understand maybe that’s how the group ride works, but my avatar would fling from side to side, and jerk forwards only to fall back. In essence, it looked like I truly sucked. Good lord, it was unnerving to have so many issues and still try to put out a good effort. Any help thrown my way would be very helpful. I’m new to this and came to the academy to ride with company and get to try to ride long periods above 3w/kg . Got stuck with a lonely ride and my avatar was clearly drunk. Surely she’s not gonna make any friends this way.

HaHa, great attitude for seeing the fun in a trying situation. Maybe there is a additional psychological component to ZA of which we were all unaware.

1 Like

Well, it’s the only alternative, no use getting upset with a game :slight_smile: I did a redo on ZA WO #1 today, not in a group and it went OK. That’s my advice for anyone else experiencing similar problems :hugs:

I had a Saris H3 and were there ever ERG mode problems with Apple TV. And how! I used to take several different devices to the pain cave to see which would work. Good for you to redo the workout and not sweat it. Okay, undoubtedly you broke a sweat. :grin: Zwift is a lot of fun and sometimes things don’t workout how one anticipates. I am getting fit and have lost nearly 25 pounds. To me, it is the most amazing tech ever.

1 Like

Elinor,

I got mine today. Half way through the ZA group ride my power flat lined at 200 watts. It took me quite awhile to figure out what was happening. I couldn’t understand why I got dropped by the group and suddenly couldn’t even find any group to hang onto. It wasn’t until the final sprint when I happened to notice that the ZC app on my iPad was showing 200 watts and the Wahoo app on my phone was showing 260. Haha, it’s just a game. Not sure what happened.

1 Like

I noticed the same issue. Zwift on PC showing 90 rpm target, while Companion tells me to spin faster to 105 rpm.

1 Like

I am seeing the same issue. I’ve had it with both workouts 1 and 2 now. App shows 90 RPM target, companion shows 105 RPM target.

1 Like

Yeah, noticed it during Academy workout #2. I was spinning at the target cadence on my laptop screen but Companion app kept nagging me to spin faster. Thankfully the important stars were awarded according to my laptop not what the Companion was asking :slight_smile:

Same issue here, in all first 3 workouts: rpm always increased by 15rpm…

Any solution yet?

same issue here, since day one

(90 (zwift windows 10) vs 105(android companion app) as an exemple)

Same issue today. Also windows 10 pro (90RPM) Android 11 (105RPM) in ZA ride.

I have observed the same thing. Zwift both on Windows 10 and Android shows 90 rpm. Android companion app shows 105 rpm - spin faster. I have been doing the workouts solo.

Another one here for Windows and Android combination.

Paired my trainer though companion app for the first time today and did ZA workout #6. Suffered this same issue. Companion wanting 105 RPM, Windows 10 wanting 90 RPM. Messed up my stars!!

Same problem… Kickr and all sensors connected to Windows PC. Companion app (Android)
asks a higher cadence…

Good Elinor,that was a very lovely post from yours,really funny if we can say,zwift is indeed a fantastic tech achievement and bugs might appear,i have been zwifting for
about 2 years with 16.000km on the mark level 40 at the moment,i use a elite direto XR perfect machine,works like the Orient Express toilet,perfectly,the only issue i’m having now is that after the 1st calibration riding is not as smooth as before and watts have dropped abt 10%,which trainer do u use?? the best is to ride via pc windows 10 and if possible with an ant+ but i dont like to use ant+ only BLE,be well&healthy and safe from all viruses.

Same here! 90rpm target on the AppleTV app but Companion set to 105rpm, constantly telling me to spin faster!

Please fix this, Zwift. It’s not a deal breaker but it’s kinda annoying. :slight_smile: :upside_down_face: