Workout / ERG question

I’m currently doing the 12 week ‘Build me up’ training plan. Lately, I’ve chosen to do the workout in Watopia on the ‘Road to Fire and Ice’ which as you know includes Alpe du Zwift.
Invariably, the workouts are between 60 and 90 mins long so they end whilst I’m still ascending the Alpe. After the workout ends I try and chose to continue riding to the top of the Alpe in order to win or unlock the Milenstein wheels.
However…the last couple of times I’ve finished a workout on the Alpe ive been having a problem with ERG mode not terminating when the workout does.

Always at the end of a workout you get a cool down period of around 5 mins let’s say and ERG mode reduces the resistance to 80w. Well, the problem I’m experiencing is that after the workout is over, it’s like ERG mode doesn’t disable and no matter how fast I pedal or in what gear on bike…I cant produce more than that 80w…so end up having to ride the rest of the Alpe around 2 to 3mph…which is bloody infuriating. This has happened the last two ascents. I’m sure the first time I ended the workout on the ascent…ERG disabled and I was able to rocket up.
Im running a new kickr core and Apple tv 4k.
Anyone know what I’m doing wrong?

Hi @Peter_Davies3, doesn’t sound like you are doing anything wrong. I use a Kickr Core as well, but with Win 10 and ANT+, and when I end a workout everything returns to normal. Do you use the companion app during the workouts? I think there is an option to toggle ERG mode on and off on the companion app. That might work, or it could be an issue with Apple TV that I’m not aware of. I have seen posted on the forums that you should force close the Zwift app on ATV after every use, or issues can pop up.

1 Like

Thanks for reply @Mike_Rowe_PBR. I do use the companion app during a workout. During the workout there is an option using the ATV remote to toggle ERG mode on and off but once the workout ends…this option disappears. As I said in my original post…its as if ERG remains on and doesn’t disable itself once the workout ends and as such I’m unable to output more wattage than whatever ERG reduced it to at the end the cooldown period (80w).
I also force close Zwift each time my ride ends.

did you update the firmware on the kickr when you got it?

1 Like

This may be completely unrelated but there have been posts before about wattage getting stuck for some people. I am not sure how many instances of this there are though. It happened to me once after my heart rate monitor battery died mid workout and the wattage was stuck. However, when I sent in a ticket I was told it had something to do with local signal interference. I have never seen it happen again but others have had similar problems. You may want to do a search for stuck wattage on the forums to find the larger threads on it.

Sure did.

i have had this problem before, and a few things seem to have “fixed” it:

  • stop pedalling for a minute or two, and see if ERG “lets go”
  • toggle ERG mode off in the action bar at the bottom of the screen
  • unplug your trainer, wait a few seconds, then plug it back in

note that i have had at least one instance where none of those things fixed it, but for the most part one of those has worked.

Thanks for the replies.
@Dan I have previously tried the stop pedalling option without success. During the workout…using the ATV remote to swipe up, there is an option to turn ERG more off and on but when the workout mode ends…this option disappears from the action bar…which is annoying. I will give the third option a go today…turning the trainer off at the power socket and then back on.
Fingers crossed.
N.B. Just had a brainwave…during the cooldown period of the workout…whilst the ‘toggle ERG mode’ on and off button is available in the action bar…I’ll try turning ERG mode off before the workout ends and then carry on riding.

That’s a good idea. I’ve had this problem myself a few times. I always force quit the Apple TV Zwift app after every ride now, seems to help. Another thought is to go into the pairing screen, unpair the control and repair it. I always forget you can do that while in game, so you don’t have to lose your spot on the route. Cheers.

Did it this morning. Workout proper done and during the 5 min cooldown I toggled ERG mode off and continued the rest of my Alpe ascent in sim mode. #tired :thinking: