ERG MODE

I am new to Zwift and I am using a Kickr trainer. I am not a big fan of the ERG Mode I feel like I would rather be in control of my own power out put when doing workouts rather than the trainer controlling my cadence to match what wattage zone I should be in. What are people thoughts of not using the ERG Mode on workouts.  Thanks for your thoughts 

Hi Ryan, just wanted to make sure you’re aware that you’re free to choose not to use ERG mode if you wish. It’s optional.

When selecting a workout, just uncheck the “Use ERG mode” selection at the bottom.

As for thoughts on ERG vs not ERG…I personally love it and wouldn’t buy a smart trainer that didn’t support ERG, but everybody is different.

Jon,

Thanks for the heads up I did notice that. I have been trying it with the ERG Mode on the last couple training rides and I can seems to get use to it. I saw I could turn it off and I plan to try it on my next work out. I would rather be in control of keeping my Watts in the proper zone rather than my trainer. What are your thoughts ??

I dont like the ERG mode during workouts. I have some very intensive and short intervals (10s all out with 400-500 Watts) and in ERG mode the resistance for that is much too high. I prefer to reach the power with cadence.

We are having the same issue as Achim Mueller, would prefer to use ERG but cant do the short sprints

I have stopped using ERG mode completely and I am much happier durning my work outs. If I ever use the just ride option I my use the ERG but it is not likely. Thanks for all your feed back.

  • for some reason my ERG only works during open riding session like 60 min riders choice, but if I choose any structured workout like the corby the ERG doesn’t work

 any advice ?

When you go into your work out selection there is a tap that says “use ERG mode” see if that is selected. See picture in above comment. I no longer use ERG mode in my structured workouts I like having control over when gear and cadence i use.

I also stopped using ERG mode.  Not because I don’t like it.  For some types of workouts I find it better than normal mode. 

 

The reason I stopped using it in Zwift is because it seems to be sloppy about transitions between segments. I takes a long time to accomodate the resistance to whatever the new resistance level is, and in the case of very short segments, it’s almost impossible to ‘Pass’ them because the software and trainer don’t adjust fast enough.

 

Without ERG mode i dont get enough resistance by just using the gears. Can only generate a certain amount of watts.    

It would be nice if when creating a workout that you could turn off ERG mode for specific blocks.   Also from what I’ve noticed during workouts with ERG mode turned on is that the Zwift doesn’t limit you to the target power very well.  It will easily let you go over the power range rather than work like other programs work and force you in quickly to the target power range.   If you speed up your cadence, the resistance should decrease, if you slow down your cadence the kickr should increase the resistance.  This doesn’t work well with Zwift.

Also don’t use ERG for swift. ERG mode works well on other platforms, but Swift still does not make ERG work well enough.

@Bill Mickey

Create a workout and drop-in a free-ride block. Free-ride blocks revert back to Level mode, not ERG mode. Then you can use the mobile app or your keyboard to increase/decrease resistance.

I use a KICKR and ERG mode and Zwift is perfect for doing workouts and hitting targets.

 

@Loureiro

could you be more specific on why you think ERG mode does not work in Zwift?

I started using Zwift recently and over the course of the last few days started a few workouts. More specifically the wringer. I too have a similar issue. No issues during the warm up & cool down modes but always during the 400+ watt effort. As soon as that interval kicks in the trainer tension goes up and the power drops. I then get a message stating ERG is temporarily disabled and then my power goes up. It seems the issue is with these short high watt efforts.

It took me a couple of sessions to fully understand the logic that determines resistance during workouts (this post really helped)… but to add to the conversation, it would be nice the road itself setting the resistance during “free ride” segments of the workouts when ERG mode is disabled. This way, you can have (for example) a 60 minute custom workout with a single “free ride” segment where the resistance is set by the virtual road. I have submitted the request (hopefully it also makes sense to other riders).

 

I hated ERG mode. Not sure if I had it setup right (if that’s possible) but I just found I would slowly grind to a halt and the resistance would become massive.

I can sort of see the point of it, but then again I find it pretty easy to follow the instructions and keep it around +/- 5 watts. 

I also like to be able to choose if I go a little under or over on a particular interval, on a particular day.

So for me, definitely no ERG.

Newbie here.  I used zwift today with ERG mode on my KICKR and had a terrible time of it during a structured workout. It seems when cadence is over 100  there is a disconnect and I found myself having to stop the bike completely before pedalling again.  are there any solutions for this to come?

@Steven:

I have a similar issue with KICKR during a mixed workout which contains 20 second  “free ride” sprint segments. I use this workout in ERG-mode.

During Warmup everything is fine. The power level is adjusted as defined in the workout. After the first sprint in the “free ride” segment I get also sometimes the message that ERG mode will be temporarily disabled. I think it depends on the high cadence I have at the end of the “free ride” sprint segment?

I also have the experience that the switching between “free ride” and ERG is rather slow. It takes nearly 5seconds until the “free ride” mode is activated and the power level from KICKR is used.

@all:
Another strange behavior:
After a while I get negative peaks.(see picture below). The red block is the “free ride” sprint segment. The longer the workout lasts the more often they seem to appear.

First I thought that errors in ANT connection are responsible for this but I have the same issue with BLE connection.

Does anybody have similar experience ?

NEWBIES - ERG MODE NEEDS TO BE TURNED OFF - Having bought a Wahoo Kickr and subscribed to Zwift I got very upset that I could not keep up on Events and felt I had wasted a lot of money because you had to be superhuman to get any value out of it - I was smashing it and doing 9kph and was always in top gear. I tried everything (lying about my weight) but no good. I was very upset and was about to throw it all in when my daughter said she’d work it out and after a couple of hours came in and said “I’ve fixed it” - she had clicked off ERG mode off and everything became more ‘real life’ and normal rescuing a $1600 investment. Yes its harder to control wattage but its much better than being made to feel like its impossible to keep up. I really wish Zwift had put something up front about ERG because I had a few very frustrating and anger generating rides and it could all have been avoided. Note to newbies like me - if you don’t want to feel like a complete loser never use ERG mode - until you understand it! And Zwift - why don’t you make this more obvious. Almost ruined the experience completely.