ERG MODE

Speaking as a new Tacx Neo user (up to date firmware and W2017 model), I find ERG mode invaluable in workout mode. It immediately reminded me of the SRM Ergometer’s I’ve used in lab sessions and performs brilliantly. Yes there is a very slight lag on the 10 second sprints but it seems Zwift deals with this by delaying the end of the interval by a couple of seconds so that you still perform gold star intervals for the specified duration. 

 

Top marks from me on a Neo, anyway, Maybe the Kickr isn’t so great?

I tried the Wringer workout last night in ERG mode on a Tacx Genius that have upgraded to the Smart version so has FE-C control. Like others the experience was somewhat mixed. In the 30 second sprints I noticed the resistance getting harder and harder so that in the last 10 seconds I could barely turn the pedals at all. In the “spinning” 2:30 sections the resistance remained very high for about half the period (e.g. 110W at about 30 rpm!!!) but as it got towards the end it eased so much that found myself doing 120-130 rpm which at least gave me a “flyer” into the sprints. That all said it was the first time I have tried this type of thing so have no baseline to judge against. As I think saw Jon Mayfield mentioning Zwift is very likely sending the “right” control to the trainer but is the trainer handling that properly and in good time and what exactly is supposed to happen. It made sense for the resistance to ease off before the sprint started to help you get your cadence up and maintain it. It made far less sense that the resistance got so hard I could not really pedal. Think will try this again with ERG mode on and off and see if either I prefer it off or better understand what cadence to apply at different times. Or maybe I just need a Tacx Neo! Any excuse :slight_smile: Doing 30 rpm or less is clearly little use to anybody!

anyone using erg mode have the tacx neo lock up? well, nearly lock up? doing 150/600 segments and in the 600 watt zone (30sec) it gets progressively harder and harder until i cannot pedal at all! i can put out 1000 on the road, so it isnt that im feeble. lol…i was standing on the pedal with full weight at an almost stand still (coasting from the inertia)…after a couple seconds it unlocks (or un-massive resistance) and i can pedal again.

Hi Bryan!

 

Same thing for me. I tried the Zwift Academy Training the other day and at the end of the 1.5h session, there were 24x 15sec 840W Sprints.

After the first six I had to give up. Pedals almost locked up at the end and I was unable - even with max power and very high cadence at the beginning of each block - to keep the pedals turning.

Why is it not possible to select ERG mode OFF and ON during a session? Why do I have to choose before I start?

I really appreciate the ERG mode for normal training, but with the high power short intervals it does not work for me.

Hi Christoph, same session, same issue. I saw it through though by letting erg mode disrngagevand teenage all 24 reps. A pretty crap way to finish a session. I love erg mode for intervals, but the tagrget it assigns me for sprints is far higher than I can do for one single fresh rep - let alone after 90mins!
I just figured it was my enduro rather than sprinters physiology. Normally I’d avoid these workouts as I can’t produce the power it ‘expects’

If you feel resistance ramping up too high, it’s usually either that your FTP is set too high for your fitness level/the workout or you’re not using ERG mode as intended.

@Cristoph - you mentioned going in at max wattage and high cadence, which is not how it’s intended to be used: you should pedal at a steady cadence throughout the workout and prior to the sprint block (unless it instructs otherwise) and let the trainer adjust resistance to match the power target. See our ERG mode guide for details. It seems unintuitive, but ERG mode on the KICKR will adjust the resistance to match the power target at a pace that’s quick enough to pass the interval if you have the leg strength. 

I’ve tried it both with ERG engaged and not engaged.  The short sharp intervals of high watts and cadence can be tricky to achieve either way.  With ERG mode engaged it doesn’t react fast enough (10sec intervals) and with ERG not engaged its really hard to match gear and cadence over such a short interval.  As an added issue with ERG engaged it can be a nightmare to balance if you have a low watt recovery period at high cadence after the high watts / high cadence interval.  Longer intervals appear to give 20 secs to achieve the target which is fine.  My issue relates to super short high wattage intervals.  At my miserbale FTP that would equate to something like 373W for 10 secs at 110 rpm.  This is sometimes followed by 100W @ 95+ rpm recovery. I’ve tried both options with my TACX trainer and on balance I’m using with ERG.  I did smile when I read reference to shifting from big to small front ring.  Big ring is still a mystery to me…not an option yet :) 

Hi Jason!

 

Thanks for your reply! My FTP was confirmed in several FTP tests and works fine for all kinds of trainings - but not the very short very high power intervals (see below).

The intervals at the end are planned at high cadence (around 110). When I did the first one, the power demand would ramp up - as expected for the ERG mode. However, the increase was so strong, that I could hardly maintain the rpm, ending up in almost locked pedals. When rpm drops far enough, it is almost impossible to get back to “normal ops” with ERG mode engaged.

During the second interval I tried to be on the “front side of the power curve”, with max effort just shortly prior to the power demand rise and with slightly above required cadence. With this “cheating”, I was able to manage six of the 24 blocks, but it was all in.

For these kind of intervals I would prefer a button (in the app) or a keyboard shortcut, to enable or disable ERG mode within the session.

I would like it if you could specify a target or minimum cadence to hold in ERG mode; I think it would help during transitions as well as for sprints.

Hi Christoph,

I have the same exact problem. I ended up going to the menu and un-pairing my Tacx Neo from the controllable trainer option for the sprints, this still made me fail the sprint section of the workout.  Then going back and pairing it for the cool down.  It would have been much better if there was a keyboard shortcut or option on the mobile app.

@Jason, this workout has a popup message that tells the user/rider that if you do not hit the 640w on the sprints that it is ok, but just do a max effort.  It seems like with those instructs that somehow the trainer should be forcing you to the specified power.

I guess I won’t be using ERG mode for the sprint workouts.  I love it for all the other workouts because it forces me to stay above FTP at a specified cadence.

Unpairing your trainer isn’t necessary. 

Just edit the workout (make a copy if it’s not editable), and replace the hard/short intervals with  'Free Ride" segment segment of the same length (I like to make them a 5 seconds or so longer to allow time to transition up/down on either end).   This will release ERG mode for just that segment and let you determine the power at the pedals using gears/cadence.

Just be ready with the right gears when it starts.  The last thing you want is to have to change gears at the start of a hard sprint interval.  I always make sure that I’m in the big ring and the middle of the cassette before ERG releases so I am at least *close* to the right gear when the free-ride segment starts.

I do this for any segment above about 110% and/or shorter than 15 seconds.   The higher the power and the shorter the segment, the more likely you will need to use ‘free ride’ to get through it.

Thanks Jim,

I’ll do this for future workouts.  I didn’t modify this one becauseI was worried about not getting the credit for the Zwift Academy workout.

Thanks for the tips.

Erg mode on my new Elite Direto is pretty awful. In a section of a workout where the power is to be 200w, the game usually will stay within 15w plus or minus if I am being really careful to pedal consistently, but most of the time I will see swings from 180 to 235 and messages to speed up or slow down. The resistance at the pedals is all over the place and it becomes very distracting. It is like a feedback loop where the trainer is responding differently than the game expects and it ends up swinging above and below the target. Only super disciplined circular cadence gets it to settle down. I have read articles online about difficult ways to map and recalibrate the trainer and the P1-P3 targets but none of that seems truly supported and certainly is sketchy. Today I did a workout with ERG off and it was much easier to shift and hit my workout targets. I do really wish I could figure out what to do to make ERG work better for my setup.

I have a Magnus.  Recently, I have noticed that when I am in Free Ride the resistance does not seem to reflect the gradient.  I have updated the firmware and tried a different Magnus trainer.  I am still hitting 250w and up in a 50-11 gear combo up Box Hill and Leith Hill.  I cannot change the “mode” on Zwift.  I use a speed/cadence senor paired to Zwift.  Although, I am not sure the speed sensor is recognized.  Anyone have any suggestions?  

Hi Robert, are you paring the Magnus trainer as both a power source and a controllable trainer?
Also, if you are in a “free ride” block of a workout, you will not feel the effect of the road gradient.

As for the speed sensor, you will not need to worry about it as long as you are pairing the Magnus as your power source.  A speed sensor would be used if you had no power source.  The Magnus now can broadcast the cadence, or you can continue pairing your separate cadence sensor.

Ride on!

 

I figured that after a workout I would still not feel gradient.  However, I am using the trainer as a power source and using it strictly in Free Ride mode.  Something is not right.