ERG Mode

Has anyone had any issues running Kickr in Erg mode since the latest update?  Typically I would log into Zwift, set wahoo app to ERG mode (vs SIM or other option)  and have access to output resistance control in Zwift just ride mode or fixed training plan.  As of 1/24/17 I can’t get erg mode to function in either setup when I am controlling the resistance.  

Anyone else having an issue?  If not are there any suggestions someone can make?  I have checked to make sure all versions (kickr, wahoo app and zwift) firmware are up to date.

Any help would be greatly appreciated.

We don’t recommend or support running the Wahoo App and Zwift at the same time as they can end up conflicting over resistance control. If you want to use ERG mode in Zwift, we recommend either using one of the pre-designed workouts or creating your own custom workout and enabling ERG mode there.


This is kind of a deal breaker!  I’ve been a Zwifter for over a year and almost always use the Wahoo app to give me high resistance on my Kickr in group rides.  Otherwise I “spin-out” on the downhills (cadence of over 120 because of the low resistance, which causes me to be dropped by the group - I’m slender, but a strong rider).  Now, ever since the volcano update, the Wahoo app defaults to “sim” mode so I’m stuck with whatever resistance Zwift decides.  For me, even in the highest gear, I’ll be dropped by groups on the downhills.  PLEASE PLEASE PLEASE, either fix this or allow a way to change resistance to a higher level in the Zwift app!  I will be devastated if I can’t ride in Zwift group rides anymore!  And yes, I have the simulation level set at 100% in Zwift.

I have also noticed this change since the Volcano update. Like Michael, I sometimes use ERG mode during group rides to keep a steady output. Before the latest update the Wahoo App settings would override Zwift, but not anymore. If anyone knows how to work around this, please let us know.

Jason . I have been using zwift exclusively on my Wahoo Kickr since I bought it and run my phone wahoo app to control my power using Bluetooth. my zwift is all on ant+ dongle. if what you say is true many people like me have and the others here have to be affected by this. Seems like zwift is going backwards

yeah this is a pain only got the kickr at xmas and was using the erg mode no problem with zwift and was looking forward to getting back to the erg sessions I was doin before my holiday. last night jumped on and it keeps just jumping to sim mode grrrr,hope this gonna get sorted

I unpaired smart trainer control bottom right of the six pairing items and ran my wahoo app in erg mode to control power all is good again



Thanks for your suggestion.  This is a partial work-around which I will have to try.  However, I enjoyed being able to switch easily between the “sim” and “erg” modes on the Wahoo app during a Zwift session.  That way I could ride “sim” on the uphills and then go to “erg” during long descents to avoid a spin-out or getting dropped during fast group rides.  Your solution will only allow you one or the other option at the beginning of a ride, and you would have to shut down and restart Zwift if you want to change modes.  Big bummer that Zwift decided to remove this very useful ability to change modes “on the fly” during a ride.


Robert…many thanks for the work around.  Its not prefect but it does work for basic training.  That is a mini win for me!

This change has been a real bummer.  I just hope Team Zwift are listening.  Frankly I had no idea others were using SIM/ERG in other ways so have to assume if we have issues…many others do too.

Thanks to all of you for your posts.


Thank you for starting this thread. I have wondered what happened to the erg mode on wahoo and why it wasn’t matching up. Super frustrating!! I like using the wahoo erg mode with Zwift. 

Why did this get changed??? not happy please listen Zwift!

Martha Long:

Please see Robert Lyman’s message above.  It’s a partial work-around and allows me to ride in Zwift using the Wahoo app once more.  It’s a bit of a pain since you can’t switch in and out of erg mode during a Zwift session, but I am able to control the power using the Wahoo app during my group rides.  I rode like this all weekend and it worked just fine.

Thanks Robert for the work around. I too felt inconvenienced by this change as I often use the Wahoo app in erg mode and dynamically change the resistance during my rides. I have also occasionally changed from erg to sim (and back) during these rides so would still prefer to have the old functionality restored.

Hi, I’m having similar problems since the volcano update.  I was able to work around by un-pairing the controllable trainer in order to use the wahoo app during a zwift ride to get more power, so that issue is solved…   But now I’m trying to use Zwift in it’s own erg mode to set a training program with specific power zones.  The power is now all over the place, it no longer controls the Wahoo Kickr to stay in one power zone.  The power zone seems to be either +10 or -10 and doesn’t stay in erg the way it used to.  My cadence is perfectly steady so there is no reason for the power to be jumping up and down like that.  The Zwift erg mode now allows the power to jump from 209 to 240 within seconds at the same cadence.  I don’t have any other bluetooth devices on, I’m on ant, and not using the wahoo app, so there should be no interference from any other devices.  It just doesn’t lock the power at my power chosen for my workout anymore.  Please help. 

Thanks for someone else finally posting this.  I have reached out to support and continue to get the same canned response; “we don’t recommend using Zwift w the wahoo app at the same time, yada yada yada.”  The fact of the matter is I’ve been using it this way exclusively always in erg mode as I train by my own coaches specific power numbers since I began using Zwift two and a half years ago.  I’ve used the Wahoo app w no problems to adjust the power to my Kickr until the volcano app came out.  Now if I use zwift and the Wahoo app my power on the trainer is uncontrollable.  Wahoo app says 200?  Kickr is reading at 250.  Shut down Zwift and automatically things work again; power reads exactly on my Garmin 810 as it does on the Wahoo app.

Again, none of this has been an issue since that update with absolutely no real explanation.

It’s a real bummer not to be able to use Zwift to pass the time particularly on those longer, 2+ hour trainer rides but that’s what I’ve had to do over the past two weeks to get the right power to show up.

+1 for this.  I reached out to support and also got the same response; “we don’t recommend using Zwift with the wahoo app” I thought it was great to set your Wahoo app in ERG mode at a constant watt to do an interval and this power would hold in Zwift. Since the update the power will not hold in Zwift. This is only since the update always worked fine before. Thanks for the recommendation about un-paring the SMART trainer will try this but wish they could look at and fix!

I should also add.  After posting about this in the Facebook user forum some guy complained that he was tired of seeing people threatening to leave Zwift over issues, that it takes time to fix problems why not get creative etc.

So I tried using the mobile app on my iPad Pro.  Using the app on bluetooth doesn’t play well at all.  If that app is running the Wahoo app doesn’t find the trainer and cadence sensor and vice versa. Turn off the app and they appear not to mention that other than having to try and create workouts there’s no way to manually adjust the wattage evenly and smoothly whenever you want in the app even in an “erg” mode.

In Zwift’s defence, trying to use multiple apps to control a single Bluetooth device is asking for trouble. Unlike Ant+, only one device can communicate with a sensor at a time. Running the Wahoo app and Zwift app at the same time is likely to cause conflicts. I don’t run the Zwift app when using the Wahoo app in erg mode, and Zwift on my PC communicates via Ant+. The iOS version may have highlighted a greater potential for issues. Maybe integrating a dynamic erg mode into the Zwift app might be a better solution?

Paul great recommendation this would be a great feature to have! Controllable ERG in Zwift :slight_smile:

I too noticed an issue using TrainerRoad via Blue Tooth iOS in conjunction with Zwift after the Volcano update.  I tried a number of things to fix it without resolve, so I opened up a ticket with TrainerRoad prior to finding this article.  I think the update to remove control of a smart trainer while in the game was deliberate.  Zwift has structured workouts and training plans making TrainerRoad a direct competitor.  I found a possible solution for my situation after looking around on youtube.  It appears that a PC with 2 ANT+ dongles can sort out Zwift and TrainerRoad and enables user ability to do TrainerRoad workouts while Zwifting.  I don’t have 2 ANT+ dongles and am wondering if anyone does and has tried this yet?  Did it fix the problem?

I connect to zwift on ant+ via my MacBook and it sees my kickr, my stages for cadence, and my tickr for heart rate.i use my iPhone Bluetooth to control my kickr power. I can switch between modes of riding with my phone app for the kick it is wahoo fitness app