Why I cannot enter Repack Ridge?

Tried all of the above and still can’t enter repack ridge. Using the app with Apple TV, can see on the map on free ride but no ? Pops up on the app to select turn on to Repack. Help needed …got Zwift so I can do MTB - very frustrating …

Realised why not running companion just Zwift on my phone …so cant ride with one apple device need two ?

Yes, you need something attached to your handlebars to steer running the companion app.

To make your u turn and repeat the Ridge, just go a couple of turns further past the entrance on your left. As for steering, I have a kinetic riser ring which allows plenty of movement, the thing that stopped me was my homemade exercise stand which I had to move even more forward to clear my tire. I had to reduce the sensitivity of steering by half to make it rideable.

Thanks. I think my issue with U-turns was more related to what @Gerrie_Delport said about holding the U button on the companion app longer (until the U-turn begins). I haven’t tried steering again since, but I noticed Elite recently launched a new steering riser, too. I’m still on the fence about buying such a thing.

No access to repack ridge today?? I had companion app on. Is it gone?

Make sure you are approaching from the right direction. Also, you will need the Companion app.

Like I said in my post : Had ZC on. And have been approaching the same way all week and riding it, then starting on 1/29 turn off was gone? Has anyone been on it today?

I’ve been trying to enter repack ridge using the Muir and the Mountain Route. The option to turn into the mtb route doesn’t appear .

I have entered this before. I don’t know what happened .

I do have my Zwift companion open and the phone on the handle bars .

I have tried maybe 5 times already and still the option doesn’t appear.

Is repack ridge closed?