Why do I sometimes ride alone?

I’ve only been on Zwift for a bit over a week.  I notice that sometimes when I ride, I seem to have the course all to myself.  In the “riders nearby” window there is only me although it indicates there are thousands of people Zwifting.

What’s up with that?  The only thing I can think of is that the servers get overwhelmed and they stop showing other riders in an attempt to keep up.

I am running Zwift on an iPad if that makes a difference.

1 Like

This is more than likely caused by a weak internet or WiFi connection on your end.

Paul,

I am literally about 10 feet from my router.  I just can’t see that is the culprit.  I never have any trouble saving my results after a ride.

I did find another post from someone reporting the same problem on her iPad.  She said rebooting the device would (temporarily??) fix the problem.  I’ll give that a try.

 

Did you adjust your world settings in the prefs file as per this article: https://zwiftinsider.com/world-tag/

If so, you would be set to a particular world where you are likely one of only a few people if that world is not the scheduled map for the day.

No, that is a good guess but I haven’t messed with that prefs file.  It looks like it is actually somewhat hard to on the iPad.

1 Like

Have you tried washing your jersey?

:wink:

Zwift, now with Smell-o-Vision ™.

I have the same issue, no one else in my group, but see the side bar with many names, and it says there are 600+ riders. I wave to the statues and bystanders!! Running it on my Apple TV.  Sure is lonely on the road…but am enjoying the ride on Zwift!! jersey washed…

 

Ahh - now we understand the reason for the price increase!

 

But seriously, I have also seen that (Mac or Apple TV) and people usually start to show up after a few minutes of just waiting.

In the cases I’ve seen, people never show up.  I do my ~1 hour ride by myself.

Possibly related, sometimes when I choose “Just Watch” I will be stuck on the introductory scenic view and never change to watching riders.  Have to force quit the app to get out.

I don’t know if this is related but I have posted the following with regards to AppleTV riding alone issue I was having. Since it is an IOS device, maybe this is applicable?

I was having the same issues.  I was using a power strip (AC on/off) to turn off my monitor and fan after finishing Zwift.  However, the AppleTV was plugged into the outlet and left running.  It was programmed to go into power savings mode after an hour of non-use.  When I wanted to use Zwift, I would turn on the monitor and launch Zwift.  After the last update I started to get the same effect you are describing - no one else was visible.  I re-booted the AppleTV and voila - all was back to normal.  The next time I used the program I was back to no one being visible.  So, I set up the AppleTV on the power strip (so it gets shut off between uses) like the monitor and now all is well.  Every time I use Zwift I have to boot up the AppleTV and I can now see others (it takes 10-20 seconds for the other riders to show up). I don’t know why or what is happening to Zwift (I assume when the AppleTV goes into power savings mode, Zwift gets fubared.) but re-boot times are very short so no real issue for me.   Hope this helps.

Marc,

Thanks for the info.  That does agree with another posting I found that indicated rebooting the device temporarily fixed it.  Fortunately (or unfortunately) I haven’t seen the problem since I posted so I have been unable to try a reboot myself.

I tend to just switch of my computer and reboot, works every time.

I have had this happen to me a couple of times in the last 2 weeks. I am also running off an iPad. Yesterday was because I didn’t update app after the new roads were added to London. The other time seems completely random.  Deleted and re installed app fixed it but not sure if there is a better solution?

You don’t need to do anything as drastic as re-installing the app.  Just force quitting the app and re-starting always fixes it for me.

1 Like