White screen on app launch

I had the same issue this morning
My MacBook isn’t able to update to Mojave but managed to update to high Sierra
It works fine now

Update to High Sierra
It will work fine

FYI: on my MacOS 10.11 the Zwift launcher did begin last night by downloading an update from Zwift. I got the white screen from this point last night and every other time when I run Zwift since.

Your hardware might not allow you to upgrade to Mojave, but I suspect you can still upgrade from El Capitan to at least Sierra (10.12) if not High Sierra (10.13). I suggest you upgrade OSX and see if that solves your problems. After all, El Capitan (10.11) came out in 2015 (?) and Apple stopped supporting it last year (2018).

@Paul_Allen This thread should probably be merged w/the “Blank Screen” one.

1 Like

My system specs are the same as they were last week when everything worked fine ?

What have you done to make my system specs no longer sufficient & why didn’t you warn customers ?

@Gerrie_Delport Does not work for Zwift and he never stated he did. Gerrie is a Watopia Wayfinder just like myself and @Daren. This is his own opinion and not that of Zwift’s and he did state that a couple of times.

I may be merging the thread with the “Blank Screen” thread as suggested by @Lin_Alan

Ride On!

I got the same problem with same script error pages. Tried reset the IE, but the error still occur… :worried:

I’m using Zwift on PC Win8.

Same for me. Not enough storage for Mojave. I was coming off Yosemite 10.10.5, but was able to update to High Sierra 10.13.6 (a smaller update) and Zwift now works fine.

1 Like

I have updated to High Sierra, which is the highest OS system my Mac can cope with, and everything is now up and running.

Same problem, running OS X 10.11. Couldn’t find the Zwiftapp link in the library folder to try the workaround mentioned above (maybe an update deleted it?) Can’t update OS X any more for my hardware and not really needing a new computer at the moment. Anyone know if Zwift is working on this or are we SOL?

Z[quote=“Ross_McNary, post:51, topic:72021”]
Can’t update OS X any more for my hardware and not really needing a new computer at the moment
[/quote]
Same here.
It’s been quite a while now and no response. Frustrating.
They could at least make a statement

What model and year Mac are you running?

Open a terminal. Then copy/paste the following:

cd ~/Library/Application\ Support/Zwift/

ZwiftApp should be there.

Ok, got it. For anyone else troubleshooting (or hopefully Zwift staff lurking and looking for solutions) the problem seems to be with the auto update that runs before Zwiftapp launches. If you can open from Zwiftapp you can save an alias on your dock bypassing the auto-updating Zwift

1 Like

I was having the same white screen issue. FWIW, I was on El Capitan and updated to High Sierra. After the update, my Zwift works again.

It’s probably academic now but I (reluctantly) updated to Sierra and Zwift worked.

I have since received an email from Zwift to say that they “rolled back the update that caused this error. You should be good to go for now.”

Hopefully everyone is now back to normal, but if not suggest you contact Zwift Support.

I used a different browser. It worked and allowed me to upgrade.

Old thread, same problem…

Yesterday the Zwift app updated to 1.0.80953 (with launcher 1.0.25) and ran fine.
Today launcher is an empty white screen… haven’t found a workaround yet.

MacOs 10.14.6 “Mojave”

edit: Zwift eventually started after several additional attempts

1 Like

Same issue for me. Worked yesterday and now just a white screen on startup. Downloaded and installed again but no change.

I restarted my computer and was able to start Zwift. However it crashed suddenly after 5 minutes of riding, and now I can’t connect any sensors. This has never happened before - it must be associated with a new update that was just installed.

Same issue. Upgrading to Bog Sur to see if it solves the issue.