White Screen after Zwift Update on Windows 10 [January 2022]

Zwift was working fine on my Windows 10 device until I ran the Zwift update yesterday. Now I just see a white screen with an ‘x’ in the upper right corner when I run Zwift. I tried reinstalling the program twice, the second time I removed all of the Zwift folders and rebooted multiple times. Nothing has worked. Please help!

2 Likes

I also had problems following the update, yesterday, on my Dell XPS 13 running Windows 10 Pro.

The screen went pink and the graphics were stretched across the screen so that they did not fit. Buttons were visibly misplaced, but the button clicks were actually where they should have been. Trying a Windows Print Screen fixed the graphics display problem temporarily.

Uninstall/reinstall did not cure the problem. However, it seems to work with greater success in windowed mode. In full screen mode the glitch with graphics reappears.

Windows is 100% up to date including graphics drivers.

1 Like

I’m having the same issue - with the same laptop. I’ll try again tonight and post on here if I get anywhere.

1 Like

Ok, I have a (partial) fix:
My XPS comes with two graphics card.
Go to the device manger and disable the ones that’s not built-in (probably Invidia)
Restart your computer
Start up Zwift - you should now see the login screen

Same issue here on Win10 since latest app update.

In my case it seems to be an issue with the standard user profile on windows.
Works fine if logged in as administrator.

Doesn’t work if I start it as administrator from the standard user profile though…?

If I start the app directly without using the launcher, it works fine, too…but has the downside of skipping a possible update…

Hmm, Mine still isn’t working and does not appear to work by starting the app directly either. I have been in contact with Zwift support but they have not been very helpful. I am getting quite frustrated over here…

If you see the white screen close Zwift ( hit the x) and try again.

1 Like

I had this this morning, closing it and trying again didn’t work but I then rebooted my PC and it worked first time.

2 Likes

Same issue also 100% up to date, only the white screen appears…

Windows 10 Home, version 21H2
Processor Intel(R) Core™ i7-2630QM CPU @2.00GHz
Zwift version=1.0.100317

I fixed by right key of the mouse and refresh the page ( CTRL+R)

2 Likes

I have this repeatedly. New today.

I worked around this using ZwiftHacks ZwiftLogin script, it works even when the launcher screen is white.

1 Like

This works in 1 out of several tries and/or reboots. It’s time consuming and simply a crap-shoot.

2 Likes

Same here - under admin profile it works fine, but with standard user it does not.

However I did get an error message one time about not being able to access folder C:\Users\Admin\AppData\Local\Zwift\something (can’t remember exact path, but pretty sure it was something like that) so I logged on as my admin user and found that this folder did not exist. Created an empty folder with the right name, logged off and back on as a standard user and this time Zwift worked - although that could just have been a fluke (haven’t tried it again since).

See White Screen after Zwift Update on Windows 10

1 Like

Me too. My current workaround is using the ZwiftHacks Zwift Login script. The fields seem to still be there, but all in white.

1 Like

I think I found the issue: (You guys need to help test my theory)

I got the white screen this morning so I opened Microsoft Edge and it asked my to sync my profile, once I told it no I could acess Zwift.

So I went ad found the setting to turn off sync and so for so good.

This how to turn of sync on Edge. Enable or Disable Sync for Profile in Microsoft Edge

I assume if you use edge and are syncing you should be good. It is only when Edge ask you to sync.

5 Likes

That would make sense. If you don’t tell it either way once it’s asked you, then it possibly craps out in the absence of a directive. I’ve not had any issues but this is probably because I’ve either not touched Edge (builds for others) or have already declined all the sync stuff (my own rig).

Potentially something @shooj can have looked at, but nice work finding a workaround. :+1:

1 Like

Is there any reason why it would fix itself? I had it a couple of times, just rebooted and it worked each time and never had it since.

2 Likes

Perhaps a reboot clears some cache which means Edge resets whether it’s awaiting an answer or not.