White Screen after Zwift Update on Windows 10

Zwift was working fine on my Windows 10 device until I ran the Zwift update yesterday. Now I just see a white screen with an ‘x’ in the upper right corner when I run Zwift. I tried reinstalling the program twice, the second time I removed all of the Zwift folders and rebooted multiple times. Nothing has worked. Please help!

I also had problems following the update, yesterday, on my Dell XPS 13 running Windows 10 Pro.

The screen went pink and the graphics were stretched across the screen so that they did not fit. Buttons were visibly misplaced, but the button clicks were actually where they should have been. Trying a Windows Print Screen fixed the graphics display problem temporarily.

Uninstall/reinstall did not cure the problem. However, it seems to work with greater success in windowed mode. In full screen mode the glitch with graphics reappears.

Windows is 100% up to date including graphics drivers.

I’m having the same issue - with the same laptop. I’ll try again tonight and post on here if I get anywhere.

Ok, I have a (partial) fix:
My XPS comes with two graphics card.
Go to the device manger and disable the ones that’s not built-in (probably Invidia)
Restart your computer
Start up Zwift - you should now see the login screen

Same issue here on Win10 since latest app update.

In my case it seems to be an issue with the standard user profile on windows.
Works fine if logged in as administrator.

Doesn’t work if I start it as administrator from the standard user profile though…?

If I start the app directly without using the launcher, it works fine, too…but has the downside of skipping a possible update…

Hmm, Mine still isn’t working and does not appear to work by starting the app directly either. I have been in contact with Zwift support but they have not been very helpful. I am getting quite frustrated over here…

If you see the white screen close Zwift ( hit the x) and try again.

1 Like

I had this this morning, closing it and trying again didn’t work but I then rebooted my PC and it worked first time.

1 Like

Same issue also 100% up to date, only the white screen appears…

Windows 10 Home, version 21H2
Processor Intel(R) Core™ i7-2630QM CPU @2.00GHz
Zwift version=1.0.100317