Wattbike Atom not feeling gradient changes

Hi,

Just started using zwift on my Windows laptop with a wattbike atom (no ANT+ dongle). It’s working fine with regards to picking up power and cadence but it seems like the controllable trainer function is not working well; there’s no detectable change in resistance on hills (this is in free ride and not a workout) and gear changes feel slightly like the bike is trying to do something on mode (resistance jumps up and down). I’ve tried doing some troubleshooting by updating the firmware on the wattbike, disconnecting and reconnecting the trainer in zwift and upping the trainer difficulty to max on zwift.

Any ideas how to solve?

Thanks!

Hello Peter, same problem for me. Using laptop with bluetooth connection. Searching how to solve this issue…started when Zwift updated 2 weeks or so ago.

Same problem here. Let us know if you find a solution!

Me too. No change of resistance as the gradient changes. Any ideas how to fix?

The specs claim it’s FE-C so the most likely case is it’s paired as a power source not a controller trainer. Verify in your pairing screen that it is paired as a controllable trainer. The other thing to verify is that the trainer resistance is set to something other than 0% (which is should be 50% by default).

These are just the obvious things to check and the issue is probably something more significant but unfortunately, I can’t help. Good luck getting it resolved.

Hmmm, I’ve been using swift with my Atom for a while ( windows/companion set up) I get the issue where the gradient is too ‘registered’ i.e. 3% gradient feels like 8-9% reflected in huge wattage increase, the atom sounds as if it’s quickly selecting gear changes ( although it’s not in ergo mode) :man_shrugging: I’m planning to reset everything and try to resolve as this happened before and doing that seemed to work…watch this space :pray:

I have the same issue and think it’s tied into the new “steering” function. If I turn off the Steering function then the gradients seem to work ok. The steering function also has the issue with the wattbike Atom that if you press the left hand hood button you will go into endless u-turns !

I am having this issue too. It only happens when I use my Wattbike Atom paired with my laptop via Bluetooth. There is no resistance change on hills. I found that if you pair you bike and laptop via the companion app, rather than direct with the laptop’s own Bluetooth, then resistance works as it should. This isn’t the perfect solution though, as occasionally, the companion app disconnects from the zwift session on the laptop, for no reason!

Thanks, I too turned it off and it seemed to be better, it’s still glitching out on cadence and power though, I’m putting it down to millions of riders on the courses overloading the system! :smiley:

I always use companion to connect with my windows tablet, just make sure no other connections are bogarting the bluetooth or wifi and it stops the drop outs…

I have exactly the same problem. I’ve just got the new Wattbike Atom and get the gradient changes if I connect with ANT+ but fixed gradient when connected via Bluetooth. Bit annoying as you can’t see gear changes on ANT+…

If everyone votes for this (top left of this page) it might get noticed by Zwift and them do something

I have the same issue. It sucks tbh. Feels like I spend more time fiddling with the Atom / Zwift / PC / Bluetooth / ANT+ than I do riding some days…

Next step for me will be to reinstall Zwift on my PC to see if that works.

Have upvoted this thread but I don’t expect that Zwift will do anything about it. They seem to spend more time inventing new cycling kits than they do making their product work properly.

I noticed this, Windows Bluetooth Wattbike Atom connection issue.

Bluetooth connection appears to be working, but, as previously described, the controller aspect of the Wattbike Atom doesn’t work.

I can use the ‘bridged’ connection to the companion app, and companion app then connecting to the Wattbike Atom, to give working controller (resistance changes from zwift).

However, this requires the companion running on the additional device, and wireless connection for the companion device.

For me there is also a more serious issue that this makes my entire Zwift configuration very sensitive to internet connectivity. If the companion Android device detects some minor disruption to connectivity, it will drop the wireless connection, and this will result in severing of the connection of Zwift to companion and Wattbike.

Note that Windows wireless may also drop (it’s much less sensitive), but in this case, the connection can be restored without loss of pairing.

I email support, and did eventually receive a reply saying “I’ve checked with our team and they’re working on a fix.”

The description of the latest zwift update included a note about a Wattbike connection fix, but it doesn’t appear to address this outstanding issue.

Anyone still having this problem, the ‘controllable’ still being picked up, but no resistance / gradient change on hills.

Works fine on my phone, but not ideal

I’ve just bought the Wattbike atom and really disappointed that a zwift verified bike doesn’t seem to change resistance with gradient when paired with my laptop. I have tried it with zwift running on my iPhone and it does pick up the gradient changes, the same with my daughters iPad.
But I wanted to use it connected to my laptop and want to use my phone running the companion app. Hi I have read that you can use the iPhone running companion app as a bridge but I can’t seem to get that to work. Feeling a bit short changed so going to address with Wattbike customer service as not what it hoped for

Absolutely fuming - just spent £2k on a Wattbike to replace my Suito smart trainer and having the same issue with no resistance on hills