Wattbike Atom Beta Update [July 2023]

Just updated my Wattbike Hub to latest version for the Beta control. I did activate the beta switch so both WattBike Hub and Zwift could run simultaneously but then decided it wasn’t something I wanted to use. I switched off the beta on the app and now when riding in free ride mode the power resistance does not change with the route ascents and descents just seems to hold on the gear resistance from the Wattbike. For example riding 0% in gear 6 shows 115 watts route changes to 3% ascent and still at 115 watts there was not change at all. If I click the gear 7 the resistance changes.

The beta update was supposed to work as which ever platform you opened 2nd then that would be the controlling platform. I have totally removed the Wattbike hub from all my devices and also uninstalled and reinstalled Zwift app and also total restart of devices to clear any cache data. But still I have the issue of Zwift route not providing the correct connection to control the Wattbike resistance?

strong text

+1 - in all regards

1 Like

Hi folks, I’m happy to help with this one. @Don_Whiley , after you switched off the beta firmware in the Wattbike Hub app, did you reconnect to the trainer (in Wattbike Hub) to revert to the previous firmware?


i also have the same problem, the difficulty slider is not working, zwift updated before the ride so it may be a bug

It’s a Wattbike issue. When I did the rollback to production firmware the bike no longer sends power to Zwift … or to Wattbike Hub. Ooops.

So, I’m now stuck with Beta Firmware and effectively no gradient info being sent from Zwift to the Wattbike. Oh, and still waiting on a response from Wattbike several days later. I’ve been happier.

1 Like


thanks this has worked, watt bike is back on previous firmware & the difficulty slider is now working

Thank you @Stuart_Bartram ! It looks like this is a side effect of the beta firmware. I’ll make sure this is known at HQ.

@David_Galbraith , I’m sorry that you’re still having issues. Please let me know if you’re having any troubles once WattBike gets you back to production firmware.

1 Like


Thanks for the reply, I have gone back to production firmware and everything is working ok

1 Like

Hello having been off zwift most of the summer and used the watt bike app lately I started back on zwift this week. I am encountering the same issue with my watt bike atom when I remove the beta software I have no power being submitted from the bike to zwift. When I run beta software it does not recognise gradient change in the resistance, power stays the same and speed reduces on hills but not the increased resistance previously witnessed. Did anyone find a solution to this?

1 Like

Try this:


1 Like

Thank you David that was the fix. All good now.


Thanks David!

This has also fixed the issue for me. I had exact same symptoms:

In beta firmware resistance stopped chaging. Switched off beta wattbike was still connecting to zwift but was not sending power reading - so I needed the „zero state” reset (i was a bit worried doing that).

I am still going to write to wattbike so they have feedback on this beta being a disaster- and to confirm that this fix is the best way (i am concerned if this could invisibly affect power accuracy)

Hi I am experiencing the same problem (no gradient change on Zwift). When resetting the zero state should this be with beta firmware or stable firmware

Try it with Beta if you want Beta. If it doesn’t work, revert to stable and try it again.

Thank you David. Worked in stable f/ware! Cheers :beers:

1 Like