Wahoo Tickr wont pair with Iphone

i cant seem to pair with my iphone. Ive tried everything, and read all the forums and ive been working with tech support for weeks with no success. Super frustrated as my race results are getting DQ’d. I bought the Tickr specifically to race on Zwift. Ive tried everything. For what its worth, the Tickr shows as connected on my phone but doesnt connect with Zwift. Wahoo said contact Zwift its their problem.

You should not pair the HR monitor to your phone. Go to bluetooth settings and “Forget” the Tickr. now open Zwift and pair it in the Zwift paring screen.


Bluetooth LE creates a 1:1 connection between devices. If your HR monitor has established a connection to the iPhone in general settings, (or another app), it’s not available to connect to the Zwift app.

Here’s a support article that about connecting heart rate monitors. In particular step 3 discusses this 1:1 connection issue.

Thanks, i did all the above. Forgot the tickr device, deleted everything off my phone that would remotely connect to a hr monitor, and nothing when i try to connect with Zwift

1 Like


Having a Bluetooth device fail to connect to the Zwift app because it’s already connected to something else is a common issue. Because this forum helps many others reading along, I hope you don’t mind that together, we can help others in the future with similar issues?

I’m going to ask you to take a second look at your iPhone’s Settings > Bluetooth menu and its list of stored devices. The list will look like something like this:

Please triple-check that the Tickr is not on your list. If it is, remove it from that list by pressing on the lower case “i” next to it, then “forget this device.” (Photo credit to osxdaily.com, which’ll walk you through the process visually.)

I work in the support team at Zwift HQ, and see an extensive discussion with our agents to get you squared away. The logs you sent indicate the Zwift app is able to find your Tickr, but can’t connect because it’s already in a state of connecting to something else. We have to be 1000% certain that you’ve taken the above step before we can go deeper into your specific situation.

I believe you when you say you done all this, and you’re frustratingly not able to connect. So I’m going to ask that we allow our agents to continue taking the next steps via email. Hope that’s ok?


Thank you for the reply and i will keep working directly with Flint. The weird thing is the Wahoo Tickr used to connect just fine, i have to think if what changed with my phone or with the Stages SC3 stationery bike i use at the gym.

I am having the same issue. The Wahoo Tickr used to connect to zwift with no issues at all, then all of a sudden it showed “connection” but did not show a signal (i.e 0 bpm). It pairs with my Wahoo Computer well enough (and shows my BPM), but Zwift does not show my BPM when it’s connected to the tkr. I disconnected it from my Wahoo Computer, and the problem persists. The tikr is not connected to any other device.

A post was merged into an existing topic: Controllable trainer is not discoverable using Zwift Companion v.3.15.0