Wahoo TCKR won't connect.


(Keith Dixon) #1

I’m using an IPhone 6 with mobile link to connect with a laptop (Windows 10)

My Wahoo cadence and speed sensors connect ok but the HR monitor won’t show up, it did a couple of times when I first started using Zwift but now won’t work at all.

It connects to my phone ok and shows up in cyclemeter and Strava but not in Zwift.

Any ideas?


(Jason K) #2

Have you tried replacing the battery? Even if it shows up in other apps, the battery may be too weak for Zwift. You should also check and make sure that it’s not paired to any other apps or programs since BLE only allows one pairing per device.


(Bastiaan Gaillard [HIK - C]) #3

I’ve had the same thing with a Garmin speed sensor. The battery didn’t connect properly. Solution was to get the battery in and out of the battery case. Solved.


(Keith Dixon) #4

I have changed the battery, no better. I’ll try another one tomorrow but I don’t think it’s that.


(Dan Crow) #5

I had to take my TCKR off and on my chest to make it reconnect. Of all my devices, it seems the most picky.


(Changren Yong (Audi)) #6

@Keith: What version of Wahoo TICKR is it? I had been using a Wahoo TICKR for quite a while without any issue on older Garmin Edge devices (like the Edge 800 and Edge 510). But the same TICKR had tons of problem pairing to newer devices like Edge 520. Even when I could get it paired, the TICKR was only sending HR to the bike computer every few minutes and would suffer from constant disconnection. According to Garmin/Wahoo, the original TICKR is not compatible even though they are all ANT+ devices. Wahoo Fitness was nice enough to give me a discount code that’s applicable on TICKR Run or TICKR X, both of which work flawlessly with the newer Garmin devices. 


(Keith Dixon) #7

The TICKR connects to everything apart from zwift so I assume the zwift mobile app is the problem. I’m just waiting for the iOS release now to try that.