Wahoo Tickr Fit invisible to MacBookPro bluetooth

I have the Wahoo Kickr Snap running through my MacBook with a wahoo cadence sensor. All works fine. I added the HRM above and the desktop search for connectivity doesn’t work. If I run it all through companion, it does but then the companion does what it likes dropping any one of the devices adhoc through the middle of a ride. As i look at the bluetooth window on the mac, the HRM is the only device that I can’t see and yet my Sony Xperia picks this up no issue. Anyone else with a similar set up and problem? Is this a Mac issue?

are you pairing it within zwift or out in the Mac OS?

With zwift running on the mac, i am trying to pair but it never finds my hrm on the search . So I checked the bluetooth prefs outside of zwift and the mac cant see the device but it does see the turbo and Cadence . Weird ,as it appears on my phone (along with the others ) no issue . Would explain why zwift desktop can’t find it …

The first thing that you should do, if you hadn’t already, is read over this article: https://support.zwift.com/en_us/i-can’t-pair-my-bluetooth-devices-(cycling)-S1DW01ZBQ

If you still have problems after that, I’d suggest reaching out to support@zwift.com, and including all of the files in your Documents/Zwift/Logs folder so that we can help you further.

Ride On!

Bluetooth is a funny, finicky thing. Its monogamous nature, and the ability for some apps to pair in the background, can cause problems.

While troubleshooting, force-stop or uninstall any app that might have paired to the hrm in the past, especially the Wahoo Utilities app. Turn off any device not involved with Zwift but that might have apps paired to the hrm.

Link no longer works. Did this solve the issue? Having exact same issue as Keir

1 Like

…same problem here. Would be great if Zwift would finally solve that problem! All other Wahoo components are working fine via BT and pair immediately…

Zwift has an article at this updated link: https://support.zwift.com/en_us/pairing-devices-HJIFDrw5S

I’m having the exact problem. Could anyone solve it? Thanks!

1 Like

Is there any answer to make Wahoo Tickr Fit works with Bluethoot for Zwift OSX with a Powerbook ? thank you

The tickr fit DOES NOT work at all on a Mac. I tried for ages and ages to get it working :frowning:

It will work with windows or iOS though.

Hi
I have exactly the same problem. The wahoo Kirk fit connected once to my MacBook through zwift but its not connecting at all now. My phone can see it, it connects to wahoo fitness app etc only the mac is the problem. Any ideas please.

Same problem here. I don’t believe this a zwift issue, but rather a wahoo/mac os issue. The work around is to connect via the companion app on your phone.

  1. Turn off BT on the mac
  2. Turn on Bt on your phone
  3. start companion app
  4. start zwift on mac
  5. On “Pair devices” screen, slect gear button top-right.
  6. select “user swift companion”

If i have any issues with this method, generally restarting my phone works.

Work around 2… get an ant+ dongle

I had the same problem and (long story short) fixed it by resetting bluetooth on OSX.

A note of caution: This will unpair all of your paired devices!

  1. Press shift + Option/Alt at the same time as you click Bluetooth in menu bar.
  2. Click on Debug > Remove all devices.
  3. Open the menu again and click Debug > Reset the Bluetooth module.
  4. Now try and re-pair your Bluetooth devices.

Notes:

  1. The solution is taken from the first result when searching for “macbook bluetooth not working” in google (I am not allowed to include links in my post).
  2. You may need to check “Show Bluetooth in menu bar”, the icon mentioned in the solution is missing (I had to).
  3. My trainer is the Kickr Core.
  4. The iPhone (Companion and Kickr app) recognized the Kickr, the MacBook not (neither Zwift app nor OSX Bluetooth Preferences).
  5. The next day after resetting the bluetooth and having connected once with the Kickr, the Kickr was then gone and would not be found anymore. I resetted the bluetooth devices again, reconnected to the Kickr and now it has been found a dozen times without needing to reset anymore. I have unplugged the Kickr, restarted and even updated the OS on the MacBook and it still works.
  6. I hope this can help others, it’s a very frustrating problem!
1 Like

Same problem. I have tried all the work arounds suggested here and on the Zwift support site. Some of them occasionally work but it never lasts. Zwift don’t even seem to acknowledge it as a specific issue. This problem seems to have been around for years. Shame on Zwift/Wahoo/Apple (whoever is responsible for not fixing this bug). It all works fine on my iPad so I can’t believe the problem is insurmountable.

1 Like

I can’t even get in touch with Zwift support anymore. They rely on Bots. I spent hours trying to find work arounds, Customer support at Zwift stinks. As much as I hate to, going back to Trainer Road.

I took in new data from your article, you are working admirably! Much obliged to you!

thank you so much this instantly solved my issue!!!

This worked perfectly for me.
Thanks very much.

I have recently got the latest mac big sur updates and now everthing connects perfectly. Issue seems to have been mac os all along.