Kickr and Tickr fine with iOS, but various problems with MacOS

I’m having problems with getting Zwift to pair with both my kickr and tickr when running Zwift from my MacBook Pro. The behaviour is just weird…sometimes it won’t find either, sometimes it finds the Kickr and says ‘connected’ but then also says ‘No Signal’, and very occasionally it finds the Tickr. There doesn’t seem to be any pattern to it…sometimes I’ll kill Zwift and restart and it finds the Kickr, sometimes it doesn’t, sometimes I’ll leave Zwift on the pairing screen for 10 mins and it’ll refuse to find either device, then I wander off to get a cuppa and when I come back 10 mins later its suddenly found them both. I used to use Zwift on the same Macbook about a year ago with no issues at all. I’ve just started using it again in last couple of weeks and its been like this from the start, both on Mojave and then Catalina. Throughout all of this, if I opened up the Wahoo utility app to see if the devices aren’t ‘pairable’, the app pairs with them straight away so its not the devices.

Then today as a last resort I thought I’d see what happens if I tried my ipad. Installed Zwift on the ipad but didn’t start it up immediately. First I tried one more time running Zwift on the Macbook to see if it would connect and again, no sign of connecting to either Kickr or Tickr after leaving it searching for them for 30 secs. Then killed Zwift on the Macbook and fired up Zwift on the ipad and it connected to both the Kickr and Tickr immediately.

There is clearly some issue with Zwift on MacOS. Is there anything else I can do to diagnose the problem?

Cheers,

Steve

the kickr and tickr can only pair with one device at a time-- maybe they are pairing with your device running the wahoo app instead of the macbook?

also, for the tickr, you have to see some flashing blue lights on it, otherwise it isn’t broadcasting itself to the computer.

i run zwift with a kickr snap and tickr on a macbook and don’t have any problems pairing them. but i always leave bluetooth off on my phone so that the wahoo app isn’t tempted to connect.

all of that said, though, i have not yet upgraded to catalina, so it could be a catalina issue. when i upgraded to high sierra there was some connections file i had to delete to get bluetooth working again, but i didn’t have any problems going to mojave.

I agree with Dan.

I have the same problem with Zwift app on my iPhone. The way around it for me is to log in to Zwift, then when Tickr not found, logout, turn off bluetooth and then on again and login to Zwift. Works every time for me - I think it is something to do with how bluetooth grabs at a particular device blocking others - I think that’s what the Llama said on a Zwiftcast a while back. May be different on the Pro but worth a go.

If the lights go out on my Tickr, I sometimes unsnap the unit from the strap and snap it back on - lights come on again.

Oh - and maybe a battery issue too on the Tickr.

Hope that helps

I’ve done all the usual checks to make sure that other devices aren’t hogging the connection. For instnace, I turned my phone off entirely, then tried pairing with Macbook with no luck. Then turn phone on and fire up wahoo utility app and it finds the kickr and tickr straight away. Same with the ipad.

There is clearly some issue with Zwift running no my macbook pro, but I’m only running the standard catalina and don’t have any other applications on the macbook that would be trying to parir with the kickr/tickr.

Its just weird…I think it needs someone from Zwift support to point me at log file or something that might help me to diagnose the issue.

Cheers.

Hi Stephen,
am I right in thinking you are using bluetooth for the main connection with your MacBook and trainer?
If so my first suggestion would be to avoid bluetooth and connect everything via
Ant+.
I have been using an old MacBook for the last 2 years without any problem. I only use Ant+ for trainer, heart rate and cadence.
When Zwift has found all these devices, only then will I enable bluetooth on the MacBook for other items.
You would need to buy an Ant+ usb stick and possibly a usb extension cable but I think it would solve your problems.
Hope this may help.

Stephen,

I’m also having the exact same problems with my MBP, except with a Tikr and a Cycleops Hammer. They worked very well until I updated to Catalina. I’ve also been able to connect to them directly from my phone, with no problem. I was also able to update the firmware on the Hammer via phone, with no problems. I guess I’m going to cancel Zwift, since I can no longer use it with my gear and Catalina. I really don’t want to spend more money on an ant+ stick as a workaround, since BT used to work. I suspect that would fix the problem. Respond back if you’ve found a solution.

What year is your MBP? Mine is a 2012.

Thanks

Hi N_Manchin,
there is a Zwift support page for bluetooth its

https://support.com/en_us/pairing_devices-HJIFDrw5S

I don’t know if you have already read that? Maybe it will be of some help.

Ant+ I find is a good system as it is in some ways more forgiving. Not that expensive in the big scheme of things. (I do understand your frustration though)

One thing to remember with bluetooth is that it is a single connection in that if a unit is connected to your phone it will not connect to your macbook. Ant+ is multi device connection. You may already know this though.

I did end up grabbing an ANT+ dongle. I found one locally at REI. Already working with no fuss. Sucks, but whatever… I’m back on the bike.

Slight consolation is that I freed up BT for my airpods…

1 Like

Hi, I never got round to buying ANT+ as just used old iPad instead which works seamlessly. Thanks for info though!

Cheers.

1 Like

Hi Stephen,
glad to hear you have fixed your problem. Thanks for the feedback.
“Ride On”

I have (had) the same issue with mu Kickr Core. My dealer replaced Core with Kickr immediately (Thanks Trek Istanbul) but same issue persists. I disconnected all my Garmin devices, phones etc, nothing has changed. Lots of cursing during trainings. All calibrations and firmware updated, both for mac and Kickr. I believe this is a communications protocols compatibility issue between platforms (Kickr, MacOS and Zwift). All will blame each other, I suppose. if anyone from Zwift asks for logs, I am here to share.
I do not want to use all dongles etc to connect an ANT+ usb adapter to use with my Macbook Pro that has onlu USB-C ports. I could not find online, Do you know ANT+ adapters for USB-C?

Hi Faith,
I guess you already know this but, I think you will need a usb-c to usb adaptor, probably a usb extension cable and a Ant+ usb stick. I don’t think there is a way around this at the present time.
Once set up with Ant+ I don’t think you will have any more problems. At least I haven’t in over 2 years.
There have been some issues with MacOS but that I think usually occurs when you have upgraded your MacOS. There are threads on this site about such issues.
Sorry if all that is of no help.

I`m having the exact same problem.
Macbook Pro Retina Early 2015 - Mac OS Catalina (always updated)
Sometimes Zwift app on Macbook sees the sensors, the Kickr, and shows “No signal”, some others times devices are not being reconized at all.

I tried my devices ( and my wifes also)
IPhone 7 & Iphone 11 zwift works great all device are working properly.
Ipad mini 3 & Ipad mini 5 zwift works great all device are working properly.

I`ve done some test… Unistall zwift on iphone & ipad nothing happens on Macbook
Bluetooth Off on both device = nothing working on macbook
All devices (no zwift installed ) turned off = nothing working on macbook

So theres clearly something wrong on the software/macbook/bluetooth managing devices (kickr and sensors). My bluetooth on the macbook works fine with keyboars, mose, earphones, headphones, etc, etc-

I ended up using mi Ipad mini with the Tacx tablet holder.

Also having the same issue - Kickr Snap, Wahoo Cadence and Wahoo Tickr all pair with Zwift on iOS. Seems only by accident will any one pair with MacBook (Catalina 10.15.6) and if so it will only be one and none of the others. Doing same thing as other folks - When attempting to pair with MacBook

  • Log out of all Zwift/Wahoo applications on iOS
  • Turn off Bluetooth on iOS
  • Make sure Wahoo Elemnt is not turned on

This is super frustrating and surprising that Zwift has not created a solution esp with so many new folks joining the platform. Forcing folks to buy additional gear (Ant+) dongle is not a good solution. At the very least, it would be great if Zwift would create the ability for the MacOS app to simply be a mirror of the iOS app - clearly there are no issues with BLE connections on iOS, so just let me connect there, but then mirror on my MacBook so I can have a larger screen.