Lost Bluetooth connection on my 8yr old MacBook Pro

Hello, since last week my MacBookPrp does not pair any more with Zwift on my WahooKickr. iPhone and iPad still work fine, but my MacBook Pro from 2012 running Catalina 10.15.7 does not. The Zwift app runs like normal, even re-installed it just a few minutes ago, other Bluetooth devices work, but my MacBook does not spot the Wahoo’s any more.

It worked perfectly before, and all of a sudden no more pairing … I already reset the bluetooth on my MacBook, no results.

Any one else have similar problems?


Since you are testing this on several devices I need to ask if it’s possible that the trainer’s Bluetooth signal is already bonded to another open Zwift session? Please power off the iPhone and iPad while you’re testing.

When you say “since last week” - have you updated macOS by any chance? If so, it’s possible that your OS reset app permissions to the default (restrictive) settings. Please read through this Support Hub article to ensure that Zwift can write to the Documents folder.

Hi, I have switched of my iPhone and iPad, no improvement. It seems that my MacBook Pro Bluetooth sees the Wahoo Kickr, but it fails to connect.

I also read the article, but the Zwift app is not in the mentioned Files and Folders but in Full Acces (see picture).

Sorry, I cannot upload any pictures here, error message

I have the same issue on a one year old MacBook Air. App works well with my iPhone, but even when I turn my iPhone off, the Zwift game in MacBook does not recognize the Wahoo Kickr. I’ve tried reinstalling Zwift after updating the Mac just yesterday with newest update, Big Sur. Still not working